Every CVE Search/ Get API key

CVE-2023-45277

Yamcs Path Traversal vulnerability

7.5 HighPublic exploitFix available

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.22%Up 1.2 points since Oct 20, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
CVE-2023-45277
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
CVE-2023-45277
Updated
2026-11-02
EUVDEUVD-2023-2824 No score

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
EUVD-2023-2824
Updated
2026-11-03
GitHub AdvisoriesGHSA-w4m2-qmh3-2g8f 7.5

Yamcs Path Traversal vulnerability

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
GHSA-w4m2-qmh3-2g8f
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-w4m2-qmh3-2g8f 7.5

Yamcs Path Traversal vulnerability

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
GHSA-w4m2-qmh3-2g8f
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV No score

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Record
CVE-2023-45277
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.yamcs:yamcs
Maven
before 5.8.7
5.8.7
org.yamcs:yamcs
Maven
before 5.8.7, plus listed versions
0.29.30.30.03.0.03.1.03.1.1
Show 45 moreShow less
3.1.23.2.03.2.13.2.23.3.03.3.13.4.03.4.13.4.113.4.23.4.33.4.43.4.53.4.63.4.84.0.04.0.14.1.14.1.24.10.04.10.14.10.24.10.34.10.44.10.54.10.64.10.74.10.84.10.94.2.04.2.14.2.24.3.04.3.14.4.04.4.14.4.24.5.04.6.04.6.14.6.24.6.34.74.7.14.7.3
5.8.7

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubshoucheng3/yamcs__yamcs_CVE-2023-45277_5-8-62025-08-17

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-45277 is a high vulnerability (CVSS 7.5) in Spaceapplications Yamcs, published October 19, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.22%, the 68th percentile. Fixed in org.yamcs:yamcs 5.8.7.

References

This page doesn't list everything

Left out here: 65 versions. The JSON record has them.

MoveEnter Open