CVE-2023-26923
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading...
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
CVE-2023-26923- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
CVE-2023-26923- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2023-30714
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
EUVD-2023-30714- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-68q9-m85g-jq3q
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading...
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
GHSA-68q9-m85g-jq3q- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
CVE-2023-26923- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-26923
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
DEBIAN-CVE-2023-26923- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-26923
7.0
Musescore 3.0 to 4.0.1 has a stack buffer overflow vulnerability that occurs when reading misconfigured midi files. If attacker can additional information, attacker can execute arbitrary code.
- Record
UBUNTU-CVE-2023-26923- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
musescore3Debian:12 |
All versions, plus listed versions 3.2.3+dfsg2-163.2.3+dfsg2-173.2.3+dfsg2-183.2.3+dfsg2-193.2.3+dfsg2-203.2.3+dfsg2-21 |
None known |
musescore3Debian:13 |
before 3.2.3+dfsg2-18 | 3.2.3+dfsg2-18 |
musescore3Debian:14 |
before 3.2.3+dfsg2-18 | 3.2.3+dfsg2-18 |
musescoreUbuntu:16.04:LTS |
All versions, plus listed versions 2.0.2+dfsg-12.0.2+dfsg-22.0.2+dfsg-2build12.0.2+dfsg-2ubuntu0.1 |
None known |
musescoreUbuntu:18.04:LTS |
All versions, plus listed versions 2.1.0+dfsg1-0.22.1.0+dfsg1-12.1.0+dfsg2-12.1.0+dfsg2-1build12.1.0+dfsg3-32.1.0+dfsg3-3build1 |
None known |
musescoreUbuntu:20.04:LTS |
All versions, plus listed versions 3.2.3+dfsg1-13.2.3+dfsg1-23.2.3+dfsg1-33.2.3+dfsg1-43.2.3+dfsg1-4build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26923 is a high vulnerability (CVSS 7.0) in Musescore, published March 28, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in musescore3 3.2.3+dfsg2-18.
References
github.com/musescore/MuseScore/issues/16346
nvd.nist.gov/vuln/detail/CVE-2023-26923
github.com/advisories/GHSA-68q9-m85g-jq3q
github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26923.json
security-tracker.debian.org/tracker/CVE-2023-26923
ubuntu.com/security/CVE-2023-26923
cve.org/CVERecord?id=CVE-2023-26923