CVE-2023-34087
An improper array index validation vulnerability exists in the EVCD var len parsing functionality...
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
CVE-2023-34087- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
EUVDEUVD-2023-38200
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
EUVD-2023-38200- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-34p4-vjw3-68hq
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality...
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
GHSA-34p4-vjw3-68hq- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
NVD
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
CVE-2023-34087- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
CVE-2023-34087- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-34087
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
DEBIAN-CVE-2023-34087- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-34087
7.8
An improper array index validation vulnerability exists in the EVCD var len parsing functionality of GTKWave 3.3.115. A specially crafted .evcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger this vulnerability.
- Record
UBUNTU-CVE-2023-34087- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gtkwaveDebian:12 |
before 3.3.118-0.1~deb12u1, plus listed versions 3.3.114-23.3.115-13.3.116-1 |
3.3.118-0.1~deb12u1 |
gtkwaveDebian:13 |
before 3.3.118-0.1 | 3.3.118-0.1 |
gtkwaveDebian:14 |
before 3.3.118-0.1 | 3.3.118-0.1 |
gtkwaveDebian:10 From an advisory covering 82 CVEs |
before 3.3.98+really3.3.118-0+deb10u1, plus listed versions 3.3.98-1 |
3.3.98+really3.3.118-0+deb10u1 |
gtkwaveDebian:11 From an advisory covering 82 CVEs |
before 3.3.104+really3.3.118-0+deb11u1, plus listed versions 3.3.104-2 |
3.3.104+really3.3.118-0+deb11u1 |
gtkwaveDebian:12 From an advisory covering 82 CVEs |
before 3.3.118-0.1~deb12u1, plus listed versions 3.3.114-23.3.115-13.3.116-1 |
3.3.118-0.1~deb12u1 |
gtkwaveUbuntu:16.04:LTS |
All versions, plus listed versions 3.3.66-1 |
None known |
gtkwaveUbuntu:18.04:LTS |
All versions, plus listed versions 3.3.82-13.3.86-1 |
None known |
gtkwaveUbuntu:20.04:LTS |
All versions, plus listed versions 3.3.101-23.3.102-13.3.103-13.3.103-1build1 |
None known |
gtkwaveUbuntu:22.04:LTS |
All versions, plus listed versions 3.3.104-23.3.104-2build1 |
None known |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
gtkwaveUbuntu:24.04:LTS |
All versions, plus listed versions 3.3.116-13.3.116-1build13.3.116-1build2 |
None known |
gtkwaveUbuntu:25.10 |
All versions, plus listed versions 3.3.121-13.3.125-1 |
None known |
gtkwaveUbuntu:26.10 |
All versions, plus listed versions 3.3.126-13.3.127-1 |
None known |
gtkwaveUbuntu:26.04:LTS |
All versions, plus listed versions 3.3.125-13.3.126-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-34087 is a high vulnerability (CVSS 7.8) in Gtkwave, published January 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in gtkwave 3.3.118-0.1~deb12u1.
References
talosintelligence.com/vulnerability_reports/TALOS-2023-1803
lists.debian.org/debian-lts-announce/2024/04/msg00007.html
nvd.nist.gov/vuln/detail/CVE-2023-34087
github.com/advisories/GHSA-34p4-vjw3-68hq
security-tracker.debian.org/tracker/CVE-2023-34087
ubuntu.com/security/CVE-2023-34087
cve.org/CVERecord?id=CVE-2023-34087