CVE-2023-38677
FPE in paddle.linalg.eig
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.7
FPE in paddle.linalg.eig
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
CVE-2023-38677- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L - Weakness
- CWE-369
- Updated
- 2026-11-02
EUVDEUVD-2024-0134
4.7
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
EUVD-2024-0134- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c6ph-m8cw-rfqh
4.7
PaddlePaddle floating point exception in paddle.linalg.eig
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
GHSA-c6ph-m8cw-rfqh- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L - Weakness
- CWE-369
- Updated
- 2026-11-02
NVD
4.7
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
CVE-2023-38677- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
OSV
7.5
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
CVE-2023-38677- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-c6ph-m8cw-rfqh
4.7
PaddlePaddle floating point exception in paddle.linalg.eig
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
GHSA-c6ph-m8cw-rfqh- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L - Weakness
- CWE-369
- Updated
- 2026-11-02
OSVPYSEC-2024-132
7.5
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
- Record
PYSEC-2024-132- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
paddlepaddlePyPI |
before 2.6.0 | 2.6.0 |
paddlepaddlePyPI |
before 2.6.0, plus listed versions 1.8.5 |
2.6.0 |
paddlepaddlePyPI |
before 2.6.0, plus listed versions 1.8.52.3.02.3.12.3.22.4.0 Show 8 moreShow less2.4.0rc02.4.12.4.22.5.02.5.0rc02.5.0rc12.5.12.5.2 |
2.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-38677 is a medium vulnerability (CVSS 4.7) in Paddlepaddle, published January 3, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in paddlepaddle 2.6.0.
References
github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-009.md
nvd.nist.gov/vuln/detail/CVE-2023-38677
github.com/PaddlePaddle/Paddle/commit/19da5c0c4d8c5e4dfef2a92e24141c3f51884dcc
github.com/pypa/advisory-database/tree/main/vulns/paddlepaddle/PYSEC-2024-132.yaml
github.com/advisories/GHSA-c6ph-m8cw-rfqh
github.com/PaddlePaddle/Paddle