CVE-2023-52307
Stack overflow in paddle.linalg.lu_unpack
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.2
Stack overflow in paddle.linalg.lu_unpack
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
CVE-2023-52307- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2024-0141
8.2
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
EUVD-2024-0141- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-g57v-2687-jx33
8.2
PaddlePaddle stack overflow in paddle.linalg.lu_unpack
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
GHSA-g57v-2687-jx33- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L - Weakness
- CWE-120, CWE-787
- Updated
- 2026-11-02
NVD
8.2
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
CVE-2023-52307- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120, CWE-787
- Updated
- 2026-11-02
OSV
9.8
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
CVE-2023-52307- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-g57v-2687-jx33
8.2
PaddlePaddle stack overflow in paddle.linalg.lu_unpack
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
GHSA-g57v-2687-jx33- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L - Weakness
- CWE-120, CWE-787
- Updated
- 2026-11-02
OSVPYSEC-2024-139
9.8
Stack overflow in paddle.linalg.lu_unpack in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.
- Record
PYSEC-2024-139- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
paddlepaddlePyPI |
before 2.6.0 | 2.6.0 |
paddlepaddlePyPI |
before 2.6.0, plus listed versions 1.8.5 |
2.6.0 |
paddlepaddlePyPI |
before 2.6.0, plus listed versions 1.8.52.3.02.3.12.3.22.4.0 Show 8 moreShow less2.4.0rc02.4.12.4.22.5.02.5.0rc02.5.0rc12.5.12.5.2 |
2.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-52307 is a high vulnerability (CVSS 8.2) in Paddlepaddle, published January 3, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in paddlepaddle 2.6.0.
References
github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-016.md
nvd.nist.gov/vuln/detail/CVE-2023-52307
github.com/PaddlePaddle/Paddle/commit/6fdb316c8b0eb747e5324907e352824c9dba8215
github.com/pypa/advisory-database/tree/main/vulns/paddlepaddle/PYSEC-2024-139.yaml
github.com/advisories/GHSA-g57v-2687-jx33
github.com/PaddlePaddle/Paddle