CVE-2020-16251
HashiCorp Vault Authentication bypass
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
8.2
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
CVE-2020-16251- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
CVE-2020-16251- Updated
- 2026-11-02
EUVDEUVD-2024-0249 No score
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
EUVD-2024-0249- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4mp7-2m29-gqxf
8.2
HashiCorp Vault Authentication bypass
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
GHSA-4mp7-2m29-gqxf- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVALPINE-CVE-2020-16251
8.2
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
ALPINE-CVE-2020-16251- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N - Updated
- 2026-11-03
OSV
8.2
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
CVE-2020-16251- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-4mp7-2m29-gqxf
8.2
HashiCorp Vault Authentication bypass
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
GHSA-4mp7-2m29-gqxf- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVBIT-vault-2020-16251 No score
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
- Record
BIT-vault-2020-16251- Updated
- 2026-11-02
OSVGO-2024-2488 No score
HashiCorp Vault Authentication bypass in github.com/hashicorp/vault
HashiCorp Vault Authentication bypass in github.com/hashicorp/vault
- Record
GO-2024-2488- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/hashicorp/vaultGo |
0.8.3 up to 1.2.5 | 1.2.5 |
github.com/hashicorp/vaultGo |
1.3.0 up to 1.3.8 | 1.3.8 |
github.com/hashicorp/vaultGo |
1.4.0 up to 1.4.4 | 1.4.4 |
github.com/hashicorp/vaultGo |
1.5.0 up to 1.5.1 | 1.5.1 |
vaultAlpine:v3.12 |
0.8.3 up to 1.4.7-r0 | 1.4.7-r0 |
vaultAlpine:v3.13 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultAlpine:v3.14 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultAlpine:v3.15 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultAlpine:v3.16 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultAlpine:v3.17 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultAlpine:v3.18 |
0.8.3 up to 1.5.4-r0 | 1.5.4-r0 |
vaultBitnami |
0.8.3 up to 1.2.5, 1.3.0 up to 1.3.8, 1.4.0 up to 1.4.4, 1.5.0 up to 1.5.1 | 1.2.51.3.81.4.41.5.1 |
github.com/hashicorp/vaultGo |
0.8.3 up to 1.2.5, 1.3.0 up to 1.3.8, 1.4.0 up to 1.4.4, 1.5.0 up to 1.5.1 | 1.2.51.3.81.4.41.5.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-16251 is a high vulnerability (CVSS 8.2) in Hashicorp Vault, published August 26, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in github.com/hashicorp/vault 1.2.5.
References
hashicorp.com/blog/category/vault
github.com/hashicorp/vault/blob/master/CHANGELOG.md
packetstormsecurity.com/files/159479/Hashicorp-Vault-GCP-IAM-Integration-Authentication-Bypass.html
nvd.nist.gov/vuln/detail/CVE-2020-16251
github.com/advisories/GHSA-4mp7-2m29-gqxf
security.alpinelinux.org/vuln/CVE-2020-16251
github.com/hashicorp/vault