Every CVE Search/ Get API key

CVE-2024-1143

Central Dogma Authentication Bypass Vulnerability via Session Leakage

9.3 CriticalFix available

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.49%Up 0.4 points since Feb 8, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.3

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Record
CVE-2024-1143
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-0477 9.3

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Record
EUVD-2024-0477
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-34q3-p352-c7q8 9.3

Central Dogma Authentication Bypass Vulnerability via Session Leakage

Vulnerability Overview

A vulnerability has been identified in Central Dogma versions prior to 0.64.1, allowing for the leakage of user sessions and subsequent authentication bypass. The issue stems from a Cross-Site Scripting (XSS) attack vector that targets the RelayState of Security Assertion Markup Language (SAML).

Impact

Successful exploitation of this vulnerability enables malicious actors to leak user sessions, leading to the compromise of authentication mechanisms. This, in turn, can facilitate unauthorized access to sensitive resources.

Patches

This vulnerability is addressed and resolved in Central Dogma version 0.64.1 Users are strongly encouraged to upgrade to this version or later to mitigate the risk associated with the authentication bypass.

Workarounds

No viable workarounds are currently available for this vulnerability. It is recommended to apply the provided patch promptly.

References

Record
GHSA-34q3-p352-c7q8
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
NVD 9.3

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Record
CVE-2024-1143
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 9.3

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Record
CVE-2024-1143
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-34q3-p352-c7q8 9.3

Central Dogma Authentication Bypass Vulnerability via Session Leakage

Vulnerability Overview

A vulnerability has been identified in Central Dogma versions prior to 0.64.1, allowing for the leakage of user sessions and subsequent authentication bypass. The issue stems from a Cross-Site Scripting (XSS) attack vector that targets the RelayState of Security Assertion Markup Language (SAML).

Impact

Successful exploitation of this vulnerability enables malicious actors to leak user sessions, leading to the compromise of authentication mechanisms. This, in turn, can facilitate unauthorized access to sensitive resources.

Patches

This vulnerability is addressed and resolved in Central Dogma version 0.64.1 Users are strongly encouraged to upgrade to this version or later to mitigate the risk associated with the authentication bypass.

Workarounds

No viable workarounds are currently available for this vulnerability. It is recommended to apply the provided patch promptly.

References

Record
GHSA-34q3-p352-c7q8
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
com.linecorp.centraldogma:centraldogma-server
Maven
before 0.64.1
0.64.1
com.linecorp.centraldogma:centraldogma-server
Maven
before 0.64.1, plus listed versions
0.17.00.18.00.19.00.20.00.20.1
Show 45 moreShow less
0.21.00.21.10.22.00.23.00.24.00.25.00.26.00.27.00.28.00.28.10.29.00.30.00.31.00.32.00.32.10.33.00.34.00.35.00.35.10.36.00.37.00.38.00.39.00.39.10.39.20.40.00.40.10.41.00.41.10.41.20.41.30.41.40.42.00.43.00.43.10.43.20.43.30.43.40.44.00.44.10.44.100.44.110.44.120.44.130.44.14
0.64.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-1143 is a critical vulnerability (CVSS 9.3) in Line Corporation Central Dogma, published February 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in com.linecorp.centraldogma:centraldogma-server 0.64.1.

References

This page doesn't list everything

Left out here: 58 versions. The JSON record has them.

MoveEnter Open