Every CVE Search/ Get API key

CVE-2024-1735

Armeria SAML authentication bypass due to missing validation on unsigned SAML messages

9.1 CriticalFix available

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.83%Up 0.8 points since Feb 26, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.1

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Record
CVE-2024-1735
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-287
Updated
2026-11-02
EUVDEUVD-2024-0511 9.1

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Record
EUVD-2024-0511
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-4m6j-23p2-8c54 9.1

Armeria SAML authentication bypass due to missing validation on unsigned SAML messages

Impact

The SAML implementation provided by armeria-saml currently accepts unsigned SAML messages (assertions, logout requests, etc.) as they are, rather than rejecting them by default. As a result, an attacker can forge a SAML message to authenticate themselves, despite the fact that such an unsigned SAML message should be rejected.

Patches

The vulnerability has been patched in Armeria version 1.27.2. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Workarounds

There is no known workaround for this vulnerability.

References

SamlMessageUtil.validateSignature()

Record
GHSA-4m6j-23p2-8c54
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-304
Updated
2026-11-02
NVD 9.1

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Record
CVE-2024-1735
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-287
Updated
2026-11-02
OSV 9.1

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Record
CVE-2024-1735
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-4m6j-23p2-8c54 9.1

Armeria SAML authentication bypass due to missing validation on unsigned SAML messages

Impact

The SAML implementation provided by armeria-saml currently accepts unsigned SAML messages (assertions, logout requests, etc.) as they are, rather than rejecting them by default. As a result, an attacker can forge a SAML message to authenticate themselves, despite the fact that such an unsigned SAML message should be rejected.

Patches

The vulnerability has been patched in Armeria version 1.27.2. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Workarounds

There is no known workaround for this vulnerability.

References

SamlMessageUtil.validateSignature()

Record
GHSA-4m6j-23p2-8c54
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-304
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
com.linecorp.armeria:armeria-saml
Maven
through 1.27.1
1.27.2
com.linecorp.armeria:armeria-saml
Maven
before 1.27.2, plus listed versions
0.69.00.70.00.70.10.71.00.71.1
Show 45 moreShow less
0.72.00.73.00.74.00.74.10.75.00.76.00.76.10.76.20.77.00.78.00.78.10.78.20.79.00.80.00.81.00.81.10.82.00.83.00.84.00.85.00.86.00.87.00.88.00.89.00.89.10.90.00.90.10.90.20.90.30.91.00.92.00.93.00.94.00.95.00.96.00.97.00.98.00.98.10.98.20.98.30.98.40.98.50.98.60.98.70.99.0
1.27.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-1735 is a critical vulnerability (CVSS 9.1) in Line Corporation Armeria, published February 26, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in com.linecorp.armeria:armeria-saml 1.27.2.

References

This page doesn't list everything

Left out here: 67 versions. The JSON record has them.

MoveEnter Open