CVE-2022-25775
SQL Injection in dynamic Reports
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.6
SQL Injection in dynamic Reports
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
- Record
CVE-2022-25775- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2024-1235
6.6
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
- Record
EUVD-2024-1235- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jj6w-2cqg-7p94
6.6
Mautic SQL Injection in dynamic Reports
Impact
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
Patches
Update to 4.4.12 or 5.0.4
Workarounds
No
References
- Record
GHSA-jj6w-2cqg-7p94- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
6.6
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
- Record
CVE-2022-25775- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
6.6
SQL Injection in dynamic Reports
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
- Record
CVE-2022-25775- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-jj6w-2cqg-7p94
6.6
Mautic SQL Injection in dynamic Reports
Impact
Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.
The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems.
Patches
Update to 4.4.12 or 5.0.4
Workarounds
No
References
- Record
GHSA-jj6w-2cqg-7p94- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mautic/corePackagist |
2.14.1 up to 4.4.12 | 4.4.12 |
mautic/corePackagist |
5.0.0-alpha up to 5.0.4 | 5.0.4 |
mautic/corePackagist |
2.14.1 up to 4.4.12, plus listed versions 2.14.22.14.2-beta2.15.02.15.0-beta2.15.1 Show 45 moreShow less2.15.1-beta2.15.22.15.2-beta2.15.32.15.3-beta2.16.02.16.0-beta2.16.12.16.1-beta2.16.22.16.2-beta2.16.32.16.3-beta2.16.42.16.53.0.03.0.0-alpha3.0.0-beta3.0.0-beta23.0.13.0.23.0.2-rc3.1.03.1.0-rc3.1.13.1.1-rc3.1.23.1.2-rc3.2.03.2.0-rc3.2.13.2.23.2.2-rc3.2.33.2.43.2.53.2.5-rc3.3.03.3.0-rc3.3.13.3.23.3.2-rc3.3.33.3.3-rc3.3.4 |
4.4.12 |
mautic/corePackagist |
5.0.0-alpha up to 5.0.4, plus listed versions 5.0.05.0.0-alpha15.0.0-beta15.0.0-beta25.0.0-rc1 Show 4 moreShow less5.0.0-rc25.0.15.0.25.0.3 |
5.0.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-25775 is a medium vulnerability (CVSS 6.6) in Acquia Mautic, published April 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in mautic/core 4.4.12.
References
github.com/mautic/mautic/security/advisories/GHSA-jj6w-2cqg-7p94
github.com/mautic/mautic/commit/cab65e0acc4f23c4f07c117dee1b69dac5abed3f
github.com/mautic/mautic/commit/e75b1eea16309588f069169b5882cf53f854dbd8
nvd.nist.gov/vuln/detail/CVE-2022-25775
github.com/advisories/GHSA-jj6w-2cqg-7p94
packagist.org
github.com/CVEProject/cvelistV5/tree/main/cves/2022/25xxx/CVE-2022-25775.json
github.com/mautic/mautic
Left out here: 32 versions. The JSON record has them.