Every CVE Search/ Get API key

CVE-2024-36694

openCart Server-Side Template Injection (SSTI) vulnerability

7.2 HighFix available

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.92%Up 0.9 points since Dec 19, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.2

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Record
CVE-2024-36694
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2024-2454 7.2

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Record
EUVD-2024-2454
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-xrh7-2gfq-4rcq 5.5

openCart Server-Side Template Injection (SSTI) vulnerability

A Server-Side Template Injection (SSTI) vulnerability in the Theme Editor Function of openCart project v4.0.2.3 allows attackers to execute arbitrary code via injecting a crafted payload.

Record
GHSA-xrh7-2gfq-4rcq
CVSS 4.0
5.5 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-94, CWE-1336
Updated
2026-11-02
NVD 7.2

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Record
CVE-2024-36694
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 7.2

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Record
CVE-2024-36694
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-xrh7-2gfq-4rcq 5.5

openCart Server-Side Template Injection (SSTI) vulnerability

A Server-Side Template Injection (SSTI) vulnerability in the Theme Editor Function of openCart project v4.0.2.3 allows attackers to execute arbitrary code via injecting a crafted payload.

Record
GHSA-xrh7-2gfq-4rcq
CVSS 4.0
5.5 MediumCVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-1336, CWE-94
Updated
2026-11-02
OSVBIT-opencart-2024-36694 No score

OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.

Record
BIT-opencart-2024-36694
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opencart/opencart
Packagist
through 4.0.2.3 None known
opencart
Bitnami
before 4.1.0
4.1.0
opencart/opencart
Packagist
through 4.0.2.3, plus listed versions
2.2.0.02.3.0.02.3.0.12.3.0.23.0.0.0
Show 18 moreShow less
3.0.0.23.0.1.13.0.1.23.0.2.03.0.3.03.0.3.13.0.3.23.0.3.33.0.3.43.0.3.53.0.3.63.0.3.73.0.3.83.0.3.93.0.4.03.0.4.13.0.5.03.0.5.1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-36694 is a high vulnerability (CVSS 7.2) in Opencart, published July 17, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in opencart 4.1.0.

References

MoveEnter Open