CVE-2024-45233
Powermail TYPO3 extension Broken Access Control in the OutputController
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
- Record
CVE-2024-45233- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
CVE List
7.3
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
- Record
CVE-2024-45233- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2024-2548
7.3
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
- Record
EUVD-2024-2548- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9jqr-5x45-pgw8
6.9
Powermail TYPO3 extension Broken Access Control in the OutputController
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
- Record
GHSA-9jqr-5x45-pgw8- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:F/RL:O/RC:C - Weakness
- CWE-284, CWE-285
- Updated
- 2026-11-02
OSVGHSA-9jqr-5x45-pgw8
6.9
Powermail TYPO3 extension Broken Access Control in the OutputController
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
- Record
GHSA-9jqr-5x45-pgw8- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:F/RL:O/RC:C - Weakness
- CWE-284, CWE-285
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
in2code/powermailPackagist |
before 7.5.0 | 7.5.0 |
in2code/powermailPackagist |
8.0.0 up to 8.5.0 | 8.5.0 |
in2code/powermailPackagist |
9.0.0 up to 10.9.0 | 10.9.0 |
in2code/powermailPackagist |
11.0.0 up to 12.4.0 | 12.4.0 |
in2code/powermailPackagist |
before 7.5.0, plus listed versions 3.10.03.10.13.11.03.11.13.11.2 Show 45 moreShow less3.12.03.13.03.14.03.15.03.16.03.17.03.18.03.18.13.18.23.19.03.2.03.20.03.21.03.21.13.22.03.22.13.3.03.4.03.5.03.6.03.7.03.8.03.9.04.0.04.0.14.0.24.1.04.2.04.3.04.3.14.3.24.3.34.3.44.3.54.4.05.0.05.0.15.1.05.2.05.2.15.2.25.3.05.3.15.3.25.4.0 |
7.5.0 |
in2code/powermailPackagist |
8.0.0 up to 8.5.0, plus listed versions 8.0.18.0.28.1.08.1.18.1.2 Show 14 moreShow less8.1.38.1.48.2.08.2.18.2.28.2.38.2.48.3.08.3.18.3.28.3.38.4.08.4.18.4.2 |
8.5.0 |
in2code/powermailPackagist |
9.0.0 up to 10.9.0, plus listed versions 10.0.010.1.010.2.010.3.010.3.1 Show 19 moreShow less10.3.210.3.310.4.010.4.110.4.210.4.310.5.010.6.010.6.110.7.010.7.110.7.210.7.310.7.410.8.010.8.110.8.29.0.19.0.2 |
10.9.0 |
in2code/powermailPackagist |
11.0.0 up to 12.4.0, plus listed versions 11.0.111.1.011.2.012.0.012.0.1 Show 12 moreShow less12.0.212.0.312.1.012.1.112.2.012.2.112.3.012.3.112.3.212.3.312.3.412.3.5 |
12.4.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-45233 is a critical vulnerability (CVSS 9.8) in In2code Powermail, published August 28, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 31st percentile. Fixed in in2code/powermail 7.5.0.
References
typo3.org/security/advisory/typo3-ext-sa-2024-006
nvd.nist.gov/vuln/detail/CVE-2024-45233
github.com/in2code-de/powermail/commit/04a010c4009202e8e1b4c72accd4d7b2771b80b3
github.com/in2code-de/powermail/commit/2c8a1bf7669eb0661e8a93164f57e4b653ac3408
github.com/in2code-de/powermail/commit/6e94ec5e0c7b553c467b826df1b922db6c2ad08e
github.com/in2code-de/powermail/commit/f56f8eefe151ad67cbd32c21f1106953b8e4f19f
github.com/advisories/GHSA-9jqr-5x45-pgw8
github.com/in2code-de/powermail
Left out here: 15 versions. The JSON record has them.