CVE-2024-28871
Excessive CPU used on malformed traffic
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Excessive CPU used on malformed traffic
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
CVE-2024-28871- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
EUVDEUVD-2024-25941
7.5
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
EUVD-2024-25941- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
NVD
7.5
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
CVE-2024-28871- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
OSV
7.5
Excessive CPU used on malformed traffic
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
CVE-2024-28871- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-28871
7.5
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
DEBIAN-CVE-2024-28871- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-28871
7.5
LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces. Version 0.5.46 may parse malformed request traffic, leading to excessive CPU usage. Version 0.5.47 contains a patch for the issue. No known workarounds are available.
- Record
UBUNTU-CVE-2024-28871- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14016-1 No score
libhtp-devel-0.5.48-2.1 on GA media
These are all security issues fixed in the libhtp-devel-0.5.48-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14016-1- Updated
- 2026-11-02
OSVUSN-7814-1 No score
libhtp vulnerabilities
It was discovered that LibHTP did not correctly handle certain HTTP headers. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2024-23837)
It was discovered that LibHTP did not correctly parse certain HTTP requests. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2024-28871)
It was discovered that LibHTP did not correctly parse certain HTTP requests. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2024-45797)
It was discovered that LibHTP did not correctly handle certain memory operations. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS and Ubuntu 25.04. (CVE-2025-53537)
- Record
USN-7814-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libhtpDebian:13 |
before 1:0.5.47-1 | 1:0.5.47-1 |
libhtpUbuntu:Pro:20.04:LTS |
before 1:0.5.32-1ubuntu0.1~esm1, plus listed versions 1:0.5.30-11:0.5.31-11:0.5.32-1 |
1:0.5.32-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:22.04:LTS |
before 1:0.5.39-1ubuntu0.1~esm1, plus listed versions 1:0.5.36-11:0.5.38-11:0.5.39-1 |
1:0.5.39-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:24.04:LTS |
before 1:0.5.46-1ubuntu2+esm1, plus listed versions 1:0.5.45-11:0.5.46-1ubuntu11:0.5.46-1ubuntu2 |
1:0.5.46-1ubuntu2+esm1 |
libhtpUbuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 0.5.15-1ubuntu0.1~esm1, plus listed versions 0.5.15-1 |
0.5.15-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:18.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.26-1ubuntu0.1~esm1, plus listed versions 1:0.5.25-11:0.5.26-1 |
1:0.5.26-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:20.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.32-1ubuntu0.1~esm1, plus listed versions 1:0.5.30-11:0.5.31-11:0.5.32-1 |
1:0.5.32-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:22.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.39-1ubuntu0.1~esm1, plus listed versions 1:0.5.36-11:0.5.38-11:0.5.39-1 |
1:0.5.39-1ubuntu0.1~esm1 |
libhtpUbuntu:Pro:24.04:LTS From an advisory covering 4 CVEs |
before 1:0.5.46-1ubuntu2+esm1, plus listed versions 1:0.5.45-11:0.5.46-1ubuntu11:0.5.46-1ubuntu2 |
1:0.5.46-1ubuntu2+esm1 |
libhtpopenSUSE:Tumbleweed |
before 0.5.48-2.1 | 0.5.48-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, published | EUVD | |
| first indexed | CVE List, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-28871 is a high vulnerability (CVSS 7.5) in Oisf Libhtp, published April 4, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in libhtp 1:0.5.47-1.
References
github.com/OISF/libhtp/security/advisories/GHSA-ffr2-45w9-7wmg
github.com/OISF/libhtp/commit/79e713f3e527593a45f545e854cd9e6fbb3cd3ed
github.com/OISF/libhtp/commit/bf618ec7f243cebfb0f7e84c3cb158955cb32b4d
redmine.openinfosecfoundation.org/issues/6757
github.com/CVEProject/cvelistV5/tree/main/cves/2024/28xxx/CVE-2024-28871.json
nvd.nist.gov/vuln/detail/CVE-2024-28871