CVE-2024-30259
FastDDS heap buffer overflow when publisher sends malformed packet
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.2
FastDDS heap buffer overflow when publisher sends malformed packet
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
CVE-2024-30259- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H - Weakness
- CWE-120, CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2024-28185
8.2
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
EUVD-2024-28185- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H - Updated
- 2026-11-03
NVD
8.2
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
CVE-2024-30259- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120, CWE-122, CWE-787
- Updated
- 2026-11-02
OSV
8.2
FastDDS heap buffer overflow when publisher sends malformed packet
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
CVE-2024-30259- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H - Weakness
- CWE-120, CWE-122
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-30259
7.5
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
DEBIAN-CVE-2024-30259- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-30259
8.2
FastDDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8, when a publisher serves malformed RTPS packet, heap buffer overflow occurs on the subscriber. This can remotely crash any Fast-DDS process, potentially leading to a DOS attack. Versions 2.14.1, 2.13.5, 2.10.4, and 2.6.8 contain a patch for the issue.
- Record
UBUNTU-CVE-2024-30259- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fastddsDebian:12 |
All versions, plus listed versions 2.10.1+ds-12.10.1+ds-22.10.1+ds-32.11.2+ds-12.11.2+ds-2 Show 27 moreShow less2.11.2+ds-32.11.2+ds-42.11.2+ds-52.11.2+ds-62.11.2+ds-6.12.11.2+ds-6.1~exp12.14.0+ds-12.14.0+ds-22.14.0+ds-32.14.0+ds-42.14.1+ds-12.14.2+ds-12.14.3+ds-12.9.1+ds-12.9.1+ds-1+deb12u12.9.1+ds-1+deb12u23.0.0+ds-13.0.0+ds-23.0.0+ds-33.0.1+ds-13.1.0+ds-13.1.0+ds-23.1.2+ds-13.3.0+ds-13.3.0+ds-23.3.0+ds-33.6.1+ds-1 |
None known |
fastddsDebian:13 |
before 2.14.1+ds-1 | 2.14.1+ds-1 |
fastddsUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 2.1.0+ds-92.4.1+ds-12.5.0+ds-32.5.0+ds-3ubuntu0.1~esm1 |
None known |
fastddsUbuntu:24.04:LTS |
All versions, plus listed versions 2.10.1+ds-32.11.2+ds-62.11.2+ds-6ubuntu12.11.2+ds-6.1build22.11.2+ds-6.1build3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-30259 is a high vulnerability (CVSS 8.2) in Eprosima Fast-dds, published May 13, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 58th percentile. Fixed in fastdds 2.14.1+ds-1.
References
github.com/eProsima/Fast-DDS/security/advisories/GHSA-qcj9-939p-p662
drive.google.com/file/d/1Y2bGvP3UIOJCLh_XEURLdhrM2Sznlvlp/view?usp=sharing
vimeo.com/907641887?share=copy
github.com/CVEProject/cvelistV5/tree/main/cves/2024/30xxx/CVE-2024-30259.json
nvd.nist.gov/vuln/detail/CVE-2024-30259
security-tracker.debian.org/tracker/CVE-2024-30259
ubuntu.com/security/CVE-2024-30259
cve.org/CVERecord?id=CVE-2024-30259