Every CVE Search/ Get API key

CVE-2024-21534

JSONPath Plus Remote Code Execution (RCE) Vulnerability

9.8 CriticalPublic exploitFix available

All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. Note: There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

9.02%Up 9.0 points since Oct 12, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.8

All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. Note: There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads.

Record
CVE-2024-21534
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P
Weakness
CWE-94, CWE-94
Updated
2026-11-02
EUVDEUVD-2024-3103 9.8

All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. Note: There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads.

Record
EUVD-2024-3103
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P
Updated
2026-11-03
GitHub AdvisoriesGHSA-pppg-cpfq-h7wr 9.3

JSONPath Plus Remote Code Execution (RCE) Vulnerability

Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.

Note:

There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads

Record
GHSA-pppg-cpfq-h7wr
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
NVD 9.8

All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. Note: There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads.

Record
CVE-2024-21534
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVGHSA-pppg-cpfq-h7wr 9.3

JSONPath Plus Remote Code Execution (RCE) Vulnerability

Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.

Note:

There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads

Record
GHSA-pppg-cpfq-h7wr
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVCLSA-2026-1774657375 No score

TuxCare security update for jsonpath-plus (1 CVE)

TuxCare rebuilt jsonpath-plus to address 1 CVE. Fixed in 7.2.0-tuxcare.2.

Record
CLSA-2026-1774657375
Updated
2026-11-02
Show 4 moreShow less
OSVCLSA-2026-1780966310 No score

TuxCare security update for jsonpath-plus (2 CVEs)

TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 5.1.0-tuxcare.1.

Record
CLSA-2026-1780966310
Updated
2026-11-02
OSVCLSA-2026-1780966312 No score

TuxCare security update for jsonpath-plus (2 CVEs)

TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 6.0.1-tuxcare.1.

Record
CLSA-2026-1780966312
Updated
2026-11-02
OSVCLSA-2026-1791290343 No score

TuxCare security update for jsonpath-plus (2 CVEs)

TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 4.0.0-tuxcare.1.

Record
CLSA-2026-1791290343
Updated
2026-11-02
OSVROOT-APP-NPM-CVE-2024-21534 No score

CVE-2024-21534 in jsonpath-plus - Patched by Root

Root has patched CVE-2024-21534 in the jsonpath-plus package for Root:npm. Multiple fixed versions available.

Record
ROOT-APP-NPM-CVE-2024-21534
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.webjars.npm:jsonpath-plus
Maven
through 6.0.1 None known
jsonpath-plus
npm
before 10.2.0
10.2.0
jsonpath-plus
TuxCare:npm
7.2.0-tuxcare.0 up to 7.2.0-tuxcare.2, plus listed versions
7.2.07.2.0-tuxcare.1
7.2.0-tuxcare.2
jsonpath-plus
TuxCare:npm
5.1.0-tuxcare.0 up to 5.1.0-tuxcare.1, plus listed versions
5.1.0
5.1.0-tuxcare.1
jsonpath-plus
TuxCare:npm
6.0.1-tuxcare.0 up to 6.0.1-tuxcare.1, plus listed versions
6.0.1
6.0.1-tuxcare.1
jsonpath-plus
TuxCare:npm
4.0.0-tuxcare.0 up to 4.0.0-tuxcare.1, plus listed versions
4.0.0
4.0.0-tuxcare.1
org.webjars.npm:jsonpath-plus
Maven
through 6.0.1, plus listed versions
3.0.04.0.0
None known
jsonpath-plus
Root:npm
before 7.2.0-aikido.6
7.2.0-aikido.67.2.0-aikido.70.19.0-aikido.1
@rootio/jsonpath-plus
Root:npm
before 7.2.0-root.io.6
7.2.0-root.io.67.2.0-root.io.70.19.0-root.io.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubBohemianHacks/CVE-2024-21534-poc2024-11-23
PoC in GitHubpabloopez/CVE-2024-215342024-11-13
PoC in GitHubverylazytech/cve-2024-215342024-11-28

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-21534 is a critical vulnerability (CVSS 9.8) in Jsonpath-plus Jsonpath, published October 11, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 9.02%, the 95th percentile. Fixed in jsonpath-plus 10.2.0.

References

Show 5 moreShow less
MoveEnter Open