CVE-2024-38856
Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
- Record
CVE-2024-38856- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
CVE List
8.1
Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
- Record
CVE-2024-38856- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
EUVDEUVD-2024-37643
8.1
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
- Record
EUVD-2024-37643- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-gp2r-34c8-48xq
8.1
Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through...
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
- Record
GHSA-gp2r-34c8-48xq- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
CISA KEV No score
Apache OFBiz Incorrect Authorization Vulnerability
Apache OFBiz contains an incorrect authorization vulnerability that could allow remote code execution via a Groovy payload in the context of the OFBiz user process by an unauthenticated attacker.
- Record
CVE-2024-38856- Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
8.1
Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code
Incorrect Authorization vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: through 18.12.14.
Users are recommended to upgrade to version 18.12.15, which fixes the issue.
Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
- Record
CVE-2024-38856- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
Affected products
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | Apache OFBiz forgotPassword/ProgramExport RCE | 2024-05-30 |
| PoC in GitHub | securelayer7/CVE-2024-38856_Scanner | 2024-08-08 |
| PoC in GitHub | Ap0dexMe0/CVE-2024-38856 | 2024-08-10 |
| PoC in GitHub | GraySignal/CVE-2024-38856-ApacheOfBiz | 2024-08-18 |
| PoC in GitHub | 0x20c/CVE-2024-38856-EXP | 2024-08-22 |
| PoC in GitHub | emanueldosreis/CVE-2024-38856 | 2024-08-27 |
| PoC in GitHub | BBD-YZZ/CVE-2024-38856-RCE | 2024-08-28 |
| PoC in GitHub | FakesiteSecurity/CVE-2024-38856_Scen | 2025-01-02 |
| PoC in GitHub | AlissonFaoli/Apache-OFBiz-Exploit | 2025-02-11 |
| PoC in GitHub | Hex00-0x4/CVE-2024-38856-Apache-OFBiz | 2025-10-10 |
| Nuclei | Apache OFBiz - Improper Authorization & Remote Code Execution |
History
| Recorded | Changed | Sources |
|---|---|---|
| exploitation, exploits | ||
| first indexed | CVE List, EUVD, GitHub Advisories, CISA KEV, Metasploit, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-38856 is a critical vulnerability (CVSS 9.8) in Apache Ofbiz, published August 5, 2024. CISA lists it as known to be exploited, since August 27, 2024. EUVD reports exploitation since August 27, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.4%, the 99th percentile. No source names a fixed version.
References
ofbiz.apache.org/download.html
ofbiz.apache.org/security.html
lists.apache.org/thread/olxxjk6b13sl3wh9cmp0k2dscvp24l7w
issues.apache.org/jira/browse/OFBIZ-13128
openwall.com/lists/oss-security/2024/08/04/1
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-38856
nvd.nist.gov/vuln/detail/CVE-2024-38856
github.com/advisories/GHSA-gp2r-34c8-48xq
github.com/CVEProject/cvelistV5/tree/main/cves/2024/38xxx/CVE-2024-38856.json