Every CVE Search/ Get API key

CVE-2024-57604

MaysWind ezBookkeeping has Improper Privilege Management

9.8 Critical

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.74%Up 0.7 points since Feb 13, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.8

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
CVE-2024-57604
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-276
Updated
2026-11-02
EUVDEUVD-2024-53641 9.8

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
EUVD-2024-53641
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-mpg8-8x9c-p9gv 9.8

MaysWind ezBookkeeping has Improper Privilege Management

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
GHSA-mpg8-8x9c-p9gv
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-269, CWE-276
Updated
2026-11-02
NVD 9.8

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
CVE-2024-57604
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-276
Updated
2026-11-02
OSV 9.8

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
CVE-2024-57604
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-mpg8-8x9c-p9gv 9.8

MaysWind ezBookkeeping has Improper Privilege Management

An issue in MaysWind ezBookkeeping 0.7.0 allows a remote attacker to escalate privileges via the token component.

Record
GHSA-mpg8-8x9c-p9gv
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-269, CWE-276
Updated
2026-11-02
OSVGO-2025-3474 No score

MaysWind ezBookkeeping has Improper Privilege Management in github.com/mayswind/ezbookkeeping

MaysWind ezBookkeeping has Improper Privilege Management in github.com/mayswind/ezbookkeeping

Record
GO-2025-3474
Updated
2026-11-02
OSVopenSUSE-SU-2025:14889-1 No score

govulncheck-vulndb-0.0.20250312T181707-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250312T181707-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14889-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/mayswind/ezbookkeeping
Go
through 0.7.0 None known
github.com/mayswind/ezbookkeeping
Go
All versions None known
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 31 CVEs
before 0.0.20250312T181707-1.1
0.0.20250312T181707-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-57604 is a critical vulnerability (CVSS 9.8) in Mayswind Ezbookkeeping, published February 12, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. No source names a fixed version.

References

Show 31 moreShow less
MoveEnter Open