CVE-2025-2161
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.1
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
- Record
CVE-2025-2161- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-10894
7.1
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
- Record
EUVD-2025-10894- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-j3pp-f94x-f42g
7.1
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
- Record
GHSA-j3pp-f94x-f42g- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
7.1
Pega Platform versions 7.2.1 to Infinity 24.2.1 are affected by an XSS issue with Mashup
- Record
CVE-2025-2161- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:14722-1 No score
rime-schema-all-20230603+git.5fdd2d6-3.1 on GA media
These are all security issues fixed in the rime-schema-all-20230603+git.5fdd2d6-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:14722-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:14902-1 No score
rime-plum-1.0.3-1.1 on GA media
These are all security issues fixed in the rime-plum-1.0.3-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:14902-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
briseopenSUSE:Tumbleweed |
before 20230603+git.5fdd2d6-3.1 | 20230603+git.5fdd2d6-3.1 |
rime-plum-goopenSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 1.0.3-1.1 | 1.0.3-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-2161 is a high vulnerability (CVSS 7.1) in Pega Platform, published February 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in brise 20230603+git.5fdd2d6-3.1.
References
support.pega.com/support-doc/pega-security-advisory-d25-vulnerability-remediation-note
nvd.nist.gov/vuln/detail/CVE-2025-2161
github.com/advisories/GHSA-j3pp-f94x-f42g
lists.opensuse.org/archives/list/[email protected]/thread/WQYYVXJX6OECNZQ2VIFPHRTWL7IRYX5K
suse.com/security/cve/CVE-2025-2161
suse.com/security/cve/CVE-2024-45337
suse.com/security/cve/CVE-2025-21613