Every CVE Search/ Get API key

CVE-2025-43971

GoBGP panics due to a zero value for softwareVersionLen

8.6 HighFix available

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.55%Up 0.5 points since Apr 21, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.6

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
CVE-2025-43971
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
EUVDEUVD-2025-12349 8.6

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
EUVD-2025-12349
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-7m35-vw2c-696v 8.6

GoBGP panics due to a zero value for softwareVersionLen

An issue was discovered in GoBGP before 3.35.0 (introduced in v3.11.0). pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
GHSA-7m35-vw2c-696v
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
NVD 8.6

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
CVE-2025-43971
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
OSV 8.6

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
CVE-2025-43971
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
OSVDEBIAN-CVE-2025-43971 7.5

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
DEBIAN-CVE-2025-43971
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVGHSA-7m35-vw2c-696v 8.6

GoBGP panics due to a zero value for softwareVersionLen

An issue was discovered in GoBGP before 3.35.0 (introduced in v3.11.0). pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
GHSA-7m35-vw2c-696v
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
OSVUBUNTU-CVE-2025-43971 8.6

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Record
UBUNTU-CVE-2025-43971
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGO-2025-3631 No score

GoBGP panics due to a zero value for softwareVersionLen in github.com/osrg/gobgp

GoBGP panics due to a zero value for softwareVersionLen in github.com/osrg/gobgp

Record
GO-2025-3631
Updated
2026-11-02
OSVopenSUSE-SU-2025:15017-1 No score

govulncheck-vulndb-0.0.20250422T181640-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250422T181640-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15017-1
Updated
2026-11-02
OSVUSN-7661-1 No score

gobgp vulnerabilities

It was discovered that GoBGP did not properly manage memory under certain circumstances, which could lead to a buffer overflow. An attacker could possibly use this issue to cause a denial of service. This issue was only addressed in Ubuntu 22.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-46565)

It was discovered that GoBGP did not properly verify the length of certain inputs. An attacker could possibly use this issue to cause a panic resulting in a denial of service. (CVE-2025-43970, CVE-2025-43971, CVE-2025-43972, CVE-2025-43973)

Record
USN-7661-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/osrg/gobgp/v3
Go
3.11.0 up to 3.35.0
3.35.0
gobgp
Debian:12
All versions, plus listed versions
3.10.0-13.16.0-13.19.0-13.21.0-13.23.0-1
Show 22 moreShow less
3.25.0-13.27.0-13.28.0-13.29.0-13.30.0-13.31.0-13.32.0-13.33.0-13.35.0-13.36.0-13.36.0-24.3.0-14.4.0-14.5.0-14.5.0-1~bpo13+14.6.0-14.6.0-24.6.0-2~bpo13+14.7.0-14.7.0-1~bpo13+14.8.0-14.8.0-2~exp1
None known
gobgp
Debian:13
before 3.35.0-1
3.35.0-1
gobgp
Debian:14
before 3.35.0-1
3.35.0-1
github.com/osrg/gobgp
Go
All versions None known
github.com/osrg/gobgp/v3
Go
before 3.35.0
3.35.0
gobgp
Ubuntu:Pro:24.04:LTS
before 3.23.0-1ubuntu0.3+esm2, plus listed versions
3.16.0-1build13.19.0-13.21.0-13.23.0-13.23.0-1ubuntu0.1
Show 4 moreShow less
3.23.0-1ubuntu0.23.23.0-1ubuntu0.2+esm13.23.0-1ubuntu0.33.23.0-1ubuntu0.3+esm1
3.23.0-1ubuntu0.3+esm2
gobgp
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 1.29-1ubuntu0.1+esm1, plus listed versions
1.15-11.29-1
1.29-1ubuntu0.1+esm1
gobgp
Ubuntu:Pro:20.04:LTS
From an advisory covering 5 CVEs
before 2.12.0-1ubuntu0.1~esm2, plus listed versions
1.33-12.11.0-12.12.0-12.12.0-1ubuntu0.1~esm1
2.12.0-1ubuntu0.1~esm2
gobgp
Ubuntu:Pro:22.04:LTS
From an advisory covering 5 CVEs
before 2.25.0-3ubuntu0.1+esm2, plus listed versions
2.25.0-22.25.0-32.25.0-3build12.25.0-3ubuntu0.12.25.0-3ubuntu0.1+esm1
2.25.0-3ubuntu0.1+esm2
gobgp
Ubuntu:Pro:24.04:LTS
From an advisory covering 5 CVEs
before 3.23.0-1ubuntu0.3+esm2, plus listed versions
3.16.0-1build13.19.0-13.21.0-13.23.0-13.23.0-1ubuntu0.1
Show 4 moreShow less
3.23.0-1ubuntu0.23.23.0-1ubuntu0.2+esm13.23.0-1ubuntu0.33.23.0-1ubuntu0.3+esm1
3.23.0-1ubuntu0.3+esm2
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 23 CVEs
before 0.0.20250422T181640-1.1
0.0.20250422T181640-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-43971 is a high vulnerability (CVSS 8.6) in Gobgp, published April 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.55%, the 46th percentile. Fixed in github.com/osrg/gobgp/v3 3.35.0.

References

Show 32 moreShow less
MoveEnter Open