CVE-2025-29746
Koillection Cross Site Scripting vulnerability
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.1
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
CVE-2025-29746- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-13924
6.1
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
EUVD-2025-13924- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-fxvx-gfmr-5xfj
6.1
Koillection Cross Site Scripting vulnerability
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
GHSA-fxvx-gfmr-5xfj- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
CVE-2025-29746- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
CVE-2025-29746- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-fxvx-gfmr-5xfj
6.1
Koillection Cross Site Scripting vulnerability
Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components
- Record
GHSA-fxvx-gfmr-5xfj- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
koillection/koillectionPackagist |
before 1.6.12 | 1.6.12 |
koillection/koillectionPackagist |
before 1.6.12, plus listed versions 1.1.71.2.01.2.11.2.21.2.3 Show 45 moreShow less1.2.41.2.51.3.01.3.11.3.101.3.111.3.121.3.131.3.141.3.151.3.161.3.171.3.181.3.21.3.31.3.41.3.51.3.61.3.71.3.81.3.91.4.01.4.11.4.101.4.111.4.121.4.131.4.21.4.31.4.41.4.51.4.61.4.71.4.81.4.91.5.01.5.11.5.101.5.111.5.121.5.131.5.141.5.151.5.21.5.3 |
1.6.12 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-29746 is a medium vulnerability (CVSS 6.1) in Benjaminjonard Koillection, published May 7, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in koillection/koillection 1.6.12.
References
github.com/benjaminjonard/koillection/issues/1329
gist.github.com/unklerunkle/73e2ab58d1a5b9129be5de55765ea4fe
nvd.nist.gov/vuln/detail/CVE-2025-29746
github.com/benjaminjonard/koillection/releases/tag/1.6.11
github.com/benjaminjonard/koillection/releases/tag/1.6.12
github.com/advisories/GHSA-fxvx-gfmr-5xfj
github.com/CVEProject/cvelistV5/tree/main/cves/2025/29xxx/CVE-2025-29746.json
github.com/benjaminjonard/koillection
Left out here: 30 versions. The JSON record has them.