Every CVE Search/ Get API key

CVE-2025-3154

Out-of-bounds array write due to invalid VerticesPerRow in Xpdf 4.05

2.1 LowFix available

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.17%Up 0.2 points since Apr 3, 2025
90%50%10%1%

What each source reports

CVE List Score used 2.1

Out-of-bounds array write due to invalid VerticesPerRow in Xpdf 4.05

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Record
CVE-2025-3154
CVSS 4.0
2.1 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2025-15084 2.1

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Record
EUVD-2025-15084
CVSS 4.0
2.1 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-xjp4-wv35-98vj 2.1

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value...

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Record
GHSA-xjp4-wv35-98vj
CVSS 4.0
2.1 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-787
Updated
2026-11-02
NVD 2.1

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Record
CVE-2025-3154
CVSS 4.0
2.1 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-787
Updated
2026-11-02
OSVUBUNTU-CVE-2025-3154 2.1

Out-of-bounds array write in Xpdf 4.05 and earlier, triggered by an invalid VerticesPerRow value in a PDF shading dictionary.

Record
UBUNTU-CVE-2025-3154
CVSS 4.0
2.1 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-02
OSVSUSE-SU-2025:3945-1 No score

Security update for poppler

This update for poppler fixes the following issues:

  • CVE-2025-3154: Fixed out-of-bounds array write due to invalid VerticesPerRow (bsc#1240687).
Record
SUSE-SU-2025:3945-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
poppler
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5
before 0.43.0-16.67.1
0.43.0-16.67.1
poppler-qt
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5
before 0.43.0-16.67.1
0.43.0-16.67.1
ipe
Ubuntu:16.04:LTS
All versions, plus listed versions
7.1.4-2.17.1.8-17.1.10-17.1.10-1.1
None known
xpdf
Ubuntu:16.04:LTS
All versions, plus listed versions
3.03-17ubuntu23.03-17ubuntu33.03-17ubuntu53.03-183.04-13.04-1build13.04-1ubuntu13.04-1ubuntu1.1
None known
ipe
Ubuntu:18.04:LTS
All versions, plus listed versions
7.2.7-27.2.7-3
None known
xpdf
Ubuntu:18.04:LTS
All versions, plus listed versions
3.04-4build13.04-53.04-5ubuntu23.04-6ubuntu13.04-7
None known
ipe
Ubuntu:20.04:LTS
All versions, plus listed versions
7.2.9-17.2.13-27.2.13-2build1
None known
ipe
Ubuntu:22.04:LTS
All versions, plus listed versions
7.2.23+dfsg1-27.2.24+dfsg1-17.2.24+dfsg1-1build1
None known
xpdf
Ubuntu:22.04:LTS
All versions, plus listed versions
3.04+git20210103-3build13.04+git20211021-13.04+git20211021-1ubuntu13.04+git20220201-1
None known
ipe
Ubuntu:24.04:LTS
All versions, plus listed versions
7.2.27+dfsg1-27.2.28-27.2.28-2.1build27.2.28-2.1build37.2.28-2.1build4
None known
Show 7 moreShow less
Affected packages
PackageAffectedFixed
xpdf
Ubuntu:24.04:LTS
All versions, plus listed versions
3.04+git20220601-1ubuntu13.04+git20220601-1ubuntu23.04+git20231213-13.04+git20240118-13.04+git20240124-1
Show 4 moreShow less
3.04+git20240202-13.04+git20240202-1build13.04+git20240202-1build23.04+git20240202-1build3
None known
ipe
Ubuntu:25.10
All versions, plus listed versions
7.2.30-1build1
None known
xpdf
Ubuntu:25.10
All versions, plus listed versions
3.04+git20250304-1
None known
ipe
Ubuntu:26.10
All versions, plus listed versions
7.2.30-1build27.2.30-2
None known
xpdf
Ubuntu:26.10
All versions, plus listed versions
3.04+git20260220-13.04+git20260220-1ubuntu13.04+git20260802-1
None known
ipe
Ubuntu:26.04:LTS
All versions, plus listed versions
7.2.30-1build17.2.30-1build2
None known
xpdf
Ubuntu:26.04:LTS
All versions, plus listed versions
3.04+git20250304-13.04+git20250304-1build13.04+git20260220-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-3154 is a low vulnerability (CVSS 2.1) in Xpdf, published April 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 5th percentile. Fixed in poppler 0.43.0-16.67.1.

References

MoveEnter Open