Every CVE Search/ Get API key

CVE-2025-40912

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode

9.8 CriticalFix available

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.41%Up 0.4 points since Jun 12, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
CVE-2025-40912
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1395
Updated
2026-11-02
EUVDEUVD-2025-18140 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
EUVD-2025-18140
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-w3qg-5chj-8g9g 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed...

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
GHSA-w3qg-5chj-8g9g
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
NVD 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
CVE-2025-40912
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode.

CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
CVE-2025-40912
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1395
Updated
2026-11-02
OSVDEBIAN-CVE-2025-40912 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode. CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
DEBIAN-CVE-2025-40912
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-40912 9.8

CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode. CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.

Record
UBUNTU-CVE-2025-40912
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-8128-1 No score

libcryptx-perl vulnerabilities

It was discovered that CryptX did not verify authentication tags while performing GCM and ChaCha20-Poly1305 decryption. An attacker could possibly use this issue to cause CryptX to accept modified ciphertext, leading to data integrity violations or authentication bypass. This issue only affected Ubuntu 18.04 LTS. (CVE-2018-25099)

It was discovered that CryptX included a version of the tomcrypt library that was susceptible to malformed unicode handling. An attacker could possibly use this issue to cause unexpected behavior or incorrect processing of crafted input. This issue only affected Ubuntu 18.04 LTS. (CVE-2025-40912)

It was discovered that CryptX included a version of the libtommath library that was susceptible to an integer overflow. An attacker could possibly use this issue to cause memory corruption or a denial of service. (CVE-2025-40914)

Record
USN-8128-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcryptx-perl
Debian:12
before 0.066-1
0.066-1
libcryptx-perl
Debian:13
before 0.066-1
0.066-1
libcryptx-perl
Debian:14
before 0.066-1
0.066-1
libcryptx-perl
Ubuntu:Pro:18.04:LTS
before 0.056-1ubuntu0.1~esm1, plus listed versions
0.055-10.056-1
0.056-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 0.056-1ubuntu0.1~esm1, plus listed versions
0.055-10.056-1
0.056-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 0.067-1ubuntu0.1~esm1, plus listed versions
0.064-10.064-1build10.066-10.067-1
0.067-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 0.076-1ubuntu0.1~esm1, plus listed versions
0.069-1build10.073-10.074-10.075-10.076-10.076-1build1
0.076-1ubuntu0.1~esm1
libcryptx-perl
Ubuntu:Pro:24.04:LTS
From an advisory covering 3 CVEs
before 0.080-2ubuntu0.1~esm1, plus listed versions
0.078-10.080-10.080-20.080-2build10.080-2build20.080-2build3
0.080-2ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-40912 is a critical vulnerability (CVSS 9.8) in Mik Cryptx, published June 11, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in libcryptx-perl 0.066-1.

References

Show 7 moreShow less
MoveEnter Open