Every CVE Search/ Get API key

CVE-2025-0781

Incorrect Authorization in SimGear

8.6 HighFix available

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.36%Up 0.3 points since Jan 29, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.6

Incorrect Authorization in SimGear

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
CVE-2025-0781
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2025-1857 8.6

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
EUVD-2025-1857
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-555q-7wq3-w6ch 8.6

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path...

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
GHSA-555q-7wq3-w6ch
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
NVD 8.6

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
CVE-2025-0781
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSV 8.6

Incorrect Authorization in SimGear

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
CVE-2025-0781
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSVDEBIAN-CVE-2025-0781 9.9

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
DEBIAN-CVE-2025-0781
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-0781 8.6

An attacker can bypass the sandboxing of Nasal scripts and arbitrarily write to any file path that the user has permission to modify at the operating-system level.

Record
UBUNTU-CVE-2025-0781
CVSS 3.1
8.6 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-06
OSVUSN-7965-1 No score

simgear vulnerability

It was discovered that SimGear could be made to bypass the sandboxing of Nasal scripts. An attacker could possibly use this issue to execute arbitrary code.

Record
USN-7965-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flightgear
Debian:12
before 1:2020.3.16+dfsg-1+deb12u1, plus listed versions
1:2020.3.16+dfsg-1
1:2020.3.16+dfsg-1+deb12u1
flightgear
Debian:13
before 1:2020.3.19+dfsg-1
1:2020.3.19+dfsg-1
simgear
Debian:12
before 1:2020.3.16+dfsg-1+deb12u1, plus listed versions
1:2020.3.16+dfsg-1
1:2020.3.16+dfsg-1+deb12u1
simgear
Debian:13
before 1:2020.3.19+dfsg-1
1:2020.3.19+dfsg-1
simgear
Debian:14
before 1:2020.3.19+dfsg-1
1:2020.3.19+dfsg-1
simgear
Debian:11
before 1:2020.3.6+dfsg-1+deb11u1, plus listed versions
1:2020.3.6+dfsg-1
1:2020.3.6+dfsg-1+deb11u1
flightgear
Debian:11
before 1:2020.3.6+dfsg-1+deb11u1, plus listed versions
1:2020.3.6+dfsg-1
1:2020.3.6+dfsg-1+deb11u1
simgear
Ubuntu:Pro:16.04:LTS
before 3.4.0-3ubuntu0.1~esm1, plus listed versions
3.4.0-2build13.4.0-3
3.4.0-3ubuntu0.1~esm1
flightgear
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.0-1build13.4.0-23.4.0-33.4.0-3ubuntu13.4.0-3ubuntu1.1
None known
simgear
Ubuntu:Pro:18.04:LTS
before 1:2018.1.1+dfsg-1ubuntu0.1~esm1, plus listed versions
1:2017.2.1+dfsg-21:2017.3.1+dfsg-21:2017.3.1+dfsg-31:2018.1.1+dfsg-1
1:2018.1.1+dfsg-1ubuntu0.1~esm1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
simgear
Ubuntu:Pro:20.04:LTS
before 1:2019.1.1+dfsg-3ubuntu0.1~esm1, plus listed versions
1:2019.1.1+dfsg-21:2019.1.1+dfsg-2build11:2019.1.1+dfsg-3~build11:2019.1.1+dfsg-3
1:2019.1.1+dfsg-3ubuntu0.1~esm1
simgear
Ubuntu:Pro:22.04:LTS
before 1:2020.3.6+dfsg-1ubuntu0.1~esm2, plus listed versions
1:2020.3.6+dfsg-1
1:2020.3.6+dfsg-1ubuntu0.1~esm2
flightgear
Ubuntu:24.04:LTS
All versions, plus listed versions
1:2020.3.18+dfsg-11:2020.3.18+dfsg-1build11:2020.3.18+dfsg-1build31:2020.3.18+dfsg-1.1
None known
simgear
Ubuntu:Pro:24.04:LTS
before 1:2020.3.18+dfsg-2.1ubuntu0.1~esm1, plus listed versions
1:2020.3.18+dfsg-21:2020.3.18+dfsg-2.1
1:2020.3.18+dfsg-2.1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, factsOSV
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-0781 is a high vulnerability (CVSS 8.6) in Flightgear Simgear, published January 28, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in flightgear 1:2020.3.16+dfsg-1+deb12u1.

References

Show 6 moreShow less
MoveEnter Open