Every CVE Search/ Get API key

CVE-2025-65713

Home Assistant Core before is vulnerable to Directory Traversal

4.0 MediumFix available

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.40%Up 0.4 points since Dec 24, 2025
90%50%10%1%

What each source reports

CVE List Score used 4.0

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
CVE-2025-65713
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2025-204808 4.0

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
EUVD-2025-204808
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-pp3g-xmm4-5cw9 6.9

Home Assistant Core before is vulnerable to Directory Traversal

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
GHSA-pp3g-xmm4-5cw9
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
Weakness
CWE-22
Updated
2026-11-02
NVD 4.0

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
CVE-2025-65713
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 4.0

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
CVE-2025-65713
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-pp3g-xmm4-5cw9 6.9

Home Assistant Core before is vulnerable to Directory Traversal

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
GHSA-pp3g-xmm4-5cw9
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
Weakness
CWE-22
Updated
2026-11-02
OSVPYSEC-2026-1454 6.9

Home Assistant Core before is vulnerable to Directory Traversal

Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.

Record
PYSEC-2026-1454
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
homeassistant
PyPI
before 2025.8.0
2025.8.0
homeassistant
PyPI
before 2025.8.0, plus listed versions
0.10.00.10.10.100.00.100.0b00.100.0b1
Show 45 moreShow less
0.100.0b20.100.0b30.100.10.100.20.100.30.101.00.101.0b00.101.0b10.101.0b20.101.0b30.101.0b40.101.10.101.20.101.30.102.00.102.0b00.102.0b10.102.0b20.102.0b30.102.10.102.20.102.30.103.00.103.0b00.103.0b10.103.10.103.20.103.30.103.40.103.50.103.60.104.00.104.0b00.104.0b10.104.0b20.104.0b30.104.0b40.104.0b50.104.10.104.20.104.30.105.00.105.0b00.105.0b50.105.0b6
2025.8.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-65713 is a medium vulnerability (CVSS 4.0) in Home-assistant, published December 23, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in homeassistant 2025.8.0.

References

This page doesn't list everything

Left out here: 1,418 versions. The JSON record has them.

MoveEnter Open