CVE-2025-15581
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's...
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation.
Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Active
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation.
Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
CVE-2025-15581- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2025-207858
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation.
Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
EUVD-2025-207858- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4wvv-g662-rjm9
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's...
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation.
Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
GHSA-4wvv-g662-rjm9- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-287
- Updated
- 2026-11-02
NVD
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation.
Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
CVE-2025-15581- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-15581
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation. Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
DEBIAN-CVE-2025-15581- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-15581
4.7
Orthanc versions before 1.12.10 are affected by an authorisation logic flaw in the application's HTTP Basic Authentication implementation. Successful exploitation could result in Privilege Escalation, potentially allowing full administrative access.
- Record
UBUNTU-CVE-2025-15581- CVSS 4.0
- 4.7 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
orthancDebian:12 |
All versions, plus listed versions 1.10.1+dfsg-21.10.1+dfsg-2+deb12u11.12.1+dfsg-11.12.1+dfsg-21.12.1+dfsg-3 Show 31 moreShow less1.12.1+dfsg-41.12.10+dfsg-11.12.10+dfsg-21.12.10+dfsg-31.12.10+dfsg-41.12.10+dfsg-51.12.11+dfsg-11.12.11+dfsg-21.12.11+dfsg-31.12.11+dfsg-41.12.11+dfsg-51.12.11+dfsg-61.12.11+dfsg-71.12.11+dfsg-81.12.2+dfsg-11.12.3+dfsg-11.12.3+dfsg-21.12.4+dfsg-11.12.4+dfsg-21.12.4+dfsg-31.12.4+dfsg-41.12.5+dfsg-11.12.5+dfsg-21.12.6+dfsg-11.12.7+dfsg-11.12.7+dfsg-21.12.7+dfsg-31.12.7+dfsg-41.12.9+dfsg-11.12.9+dfsg-21.13.0+dfsg-1 |
None known |
orthancDebian:13 |
All versions, plus listed versions 1.12.10+dfsg-11.12.10+dfsg-21.12.10+dfsg-31.12.10+dfsg-41.12.10+dfsg-5 Show 12 moreShow less1.12.11+dfsg-11.12.11+dfsg-21.12.11+dfsg-31.12.11+dfsg-41.12.11+dfsg-51.12.11+dfsg-61.12.11+dfsg-71.12.11+dfsg-81.12.7+dfsg-41.12.9+dfsg-11.12.9+dfsg-21.13.0+dfsg-1 |
None known |
orthancDebian:14 |
before 1.12.10+dfsg-1, plus listed versions 1.12.7+dfsg-41.12.9+dfsg-11.12.9+dfsg-2 |
1.12.10+dfsg-1 |
orthancDebian:11 |
before 1.9.2+really1.9.1+dfsg-1+deb11u2, plus listed versions 1.9.2+really1.9.1+dfsg-11.9.2+really1.9.1+dfsg-1+deb11u1 |
1.9.2+really1.9.1+dfsg-1+deb11u2 |
orthancUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.4+dfsg-10.9.4+dfsg-20.9.5+dfsg-11.0.0+dfsg-11.0.0+dfsg-1build1 |
None known |
orthancUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.0+dfsg-1build11.3.0+dfsg-1build21.3.1+dfsg-11.3.1+dfsg-1build11.3.1+dfsg-1build2 |
None known |
orthancUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.7+dfsg-21.5.8+dfsg-21.5.8+dfsg-2ubuntu21.5.8+dfsg-2ubuntu31.5.8+dfsg-2ubuntu41.5.8+dfsg-2ubuntu51.5.8+dfsg-2ubuntu6 |
None known |
orthancUbuntu:22.04:LTS |
All versions, plus listed versions 1.9.2+really1.9.1+dfsg-11.9.7+dfsg-3ubuntu11.9.7+dfsg-3ubuntu21.9.7+dfsg-41.9.7+dfsg-51.9.7+dfsg-61.10.0+dfsg-1 |
None known |
orthancUbuntu:24.04:LTS |
All versions, plus listed versions 1.12.1+dfsg-31.12.1+dfsg-41.12.1+dfsg-4build11.12.2+dfsg-11.12.2+dfsg-1build31.12.2+dfsg-1build4 |
None known |
orthancUbuntu:25.10 |
All versions, plus listed versions 1.12.6+dfsg-11.12.7+dfsg-41.12.7+dfsg-4build2 |
None known |
orthancUbuntu:26.10 |
All versions, plus listed versions 1.12.10+dfsg-21.12.11+dfsg-81.12.11+dfsg-8build1 |
None known |
orthancUbuntu:26.04:LTS |
All versions, plus listed versions 1.12.7+dfsg-4build21.12.9+dfsg-21.12.10+dfsg-11.12.10+dfsg-1build11.12.10+dfsg-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-15581 is a medium vulnerability (CVSS 4.7) in Orthanc-server Orthanc, published February 18, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in orthanc 1.12.10+dfsg-1.
References
projectblack.io/blog/orthanc-1-12-9-user-impersonation
discourse.orthanc-server.org/t/orthanc-1-12-10/6326
orthanc.uclouvain.be/bugs/show_bug.cgi?id=252
lists.debian.org/debian-lts-announce/2026/02/msg00033.html
nvd.nist.gov/vuln/detail/CVE-2025-15581
github.com/advisories/GHSA-4wvv-g662-rjm9
security-tracker.debian.org/tracker/CVE-2025-15581
ubuntu.com/security/CVE-2025-15581
cve.org/CVERecord?id=CVE-2025-15581