CVE-2025-1302
JSONPath Plus allows Remote Code Execution
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. Note: This is caused by an incomplete fix for CVE-2024-21534.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.3
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. Note: This is caused by an incomplete fix for CVE-2024-21534.
- Record
CVE-2025-1302- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2025-2104
9.3
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. Note: This is caused by an incomplete fix for CVE-2024-21534.
- Record
EUVD-2025-2104- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hw8r-x6gr-5gjp
8.9
JSONPath Plus allows Remote Code Execution
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode.
Note:
This is caused by an incomplete fix for CVE-2024-21534.
- Record
GHSA-hw8r-x6gr-5gjp- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
8.9
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. Note: This is caused by an incomplete fix for CVE-2024-21534.
- Record
CVE-2025-1302- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
8.9
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. Note: This is caused by an incomplete fix for CVE-2024-21534.
- Record
CVE-2025-1302- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-hw8r-x6gr-5gjp
8.9
JSONPath Plus allows Remote Code Execution
Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode.
Note:
This is caused by an incomplete fix for CVE-2024-21534.
- Record
GHSA-hw8r-x6gr-5gjp- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
Show 6 moreShow less
OSVCLSA-2026-1774657371 No score
TuxCare security update for jsonpath-plus (2 CVEs)
TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 7.2.0-tuxcare.1.
- Record
CLSA-2026-1774657371- Updated
- 2026-11-02
OSVCLSA-2026-1780966310 No score
TuxCare security update for jsonpath-plus (2 CVEs)
TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 5.1.0-tuxcare.1.
- Record
CLSA-2026-1780966310- Updated
- 2026-11-02
OSVCLSA-2026-1780966312 No score
TuxCare security update for jsonpath-plus (2 CVEs)
TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 6.0.1-tuxcare.1.
- Record
CLSA-2026-1780966312- Updated
- 2026-11-02
OSVCLSA-2026-1791290343 No score
TuxCare security update for jsonpath-plus (2 CVEs)
TuxCare rebuilt jsonpath-plus to address 2 CVEs. Fixed in 4.0.0-tuxcare.1.
- Record
CLSA-2026-1791290343- Updated
- 2026-11-02
OSVROOT-APP-NPM-AIKIDO-2024-10345 No score
AIKIDO-2024-10345 in jsonpath-plus - Patched by Root
Root has patched AIKIDO-2024-10345 in the jsonpath-plus package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-AIKIDO-2024-10345- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2025-1302 No score
CVE-2025-1302 in jsonpath-plus - Patched by Root
Root has patched CVE-2025-1302 in the jsonpath-plus package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2025-1302- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jsonpath-plusnpm |
before 10.3.0 | 10.3.0 |
jsonpath-plusTuxCare:npm |
7.2.0-tuxcare.0 up to 7.2.0-tuxcare.1, plus listed versions 7.2.0 |
7.2.0-tuxcare.1 |
jsonpath-plusTuxCare:npm |
5.1.0-tuxcare.0 up to 5.1.0-tuxcare.1, plus listed versions 5.1.0 |
5.1.0-tuxcare.1 |
jsonpath-plusTuxCare:npm |
6.0.1-tuxcare.0 up to 6.0.1-tuxcare.1, plus listed versions 6.0.1 |
6.0.1-tuxcare.1 |
jsonpath-plusTuxCare:npm |
4.0.0-tuxcare.0 up to 4.0.0-tuxcare.1, plus listed versions 4.0.0 |
4.0.0-tuxcare.1 |
jsonpath-plusRoot:npm |
before 7.2.0-aikido.7 | 7.2.0-aikido.7 |
@rootio/jsonpath-plusRoot:npm |
before 7.2.0-root.io.7 | 7.2.0-root.io.7 |
jsonpath-plusRoot:npm |
before 7.2.0-aikido.2 | 7.2.0-aikido.27.2.0-aikido.37.2.0-aikido.47.2.0-aikido.57.2.0-aikido.67.2.0-aikido.7 |
@rootio/jsonpath-plusRoot:npm |
before 7.2.0-root.io.1 | 7.2.0-root.io.17.2.0-root.io.27.2.0-root.io.37.2.0-root.io.47.2.0-root.io.57.2.0-root.io.67.2.0-root.io.7 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | JSONPath Plus < 10.3.0 - Remote Code Execution | |
| PoC in GitHub | EQSTLab/CVE-2025-1302 | 2025-02-25 |
| PoC in GitHub | abrewer251/CVE-2025-1302_jsonpath-plus_RCE | 2025-07-24 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-1302 is a critical vulnerability (CVSS 9.3) in jsonpath-plus, published February 15, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.4%, the 95th percentile. Fixed in jsonpath-plus 10.3.0.
References
security.snyk.io/vuln/SNYK-JS-JSONPATHPLUS-8719585
gist.github.com/nickcopi/11ba3cb4fdee6f89e02e6afae8db6456
github.com/JSONPath-Plus/JSONPath/blob/8e4acf8aff5f446aa66323e12394ac5615c3b260/src/Safe-Script.js%23L127
github.com/JSONPath-Plus/JSONPath/commit/30942896d27cb8a806b965a5ca9ef9f686be24ee
nvd.nist.gov/vuln/detail/CVE-2025-1302
nvd.nist.gov/vuln/detail/CVE-2024-21534