Every CVE Search/ Get API key

CVE-2025-54313

eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

7.5 HighIn KEVPublic exploitFix available

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
None

Exploit likelihood

5.12%Up 5.1 points since Jul 20, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
CVE-2025-54313
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-506
Updated
2026-11-02
EUVDEUVD-2025-21972 7.5

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
EUVD-2025-21972
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-f29h-pxvx-f335 7.5

eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
GHSA-f29h-pxvx-f335
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-506
Updated
2026-11-02
CISA KEV No score

Prettier eslint-config-prettier Embedded Malicious Code Vulnerability

Prettier eslint-config-prettier contains an embedded malicious code vulnerability. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
CVE-2025-54313
Weakness
CWE-506
Updated
2026-11-02
NVD 7.5

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
CVE-2025-54313
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-506
Updated
2026-11-02
OSV 7.5

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
CVE-2025-54313
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-506
Updated
2026-11-02
OSVGHSA-f29h-pxvx-f335 7.5

eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Record
GHSA-f29h-pxvx-f335
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-506
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
eslint-config-prettier
npm
8.10.1 to 8.10.1
8.10.2
eslint-config-prettier
npm
9.1.1 to 9.1.1
9.1.2
eslint-config-prettier
npm
10.1.6 to 10.1.7
10.1.8
eslint-plugin-prettier
npm
4.2.2 to 4.2.3
4.2.4
synckit
npm
0.11.9 to 0.11.9
0.11.10
@pkgr/core
npm
0.2.8 to 0.2.8
0.2.9
napi-postinstall
npm
0.3.1 to 0.3.1
0.3.2
got-fetch
npm
5.1.11 to 5.1.12
6.0.0
eslint-config-prettier
npm
8.10.1 up to 8.10.2
8.10.2
eslint-config-prettier
npm
9.1.1 up to 9.1.2
9.1.2
Show 6 moreShow less
Affected packages
PackageAffectedFixed
eslint-config-prettier
npm
10.1.6 up to 10.1.8
10.1.8
eslint-plugin-prettier
npm
4.2.2 up to 4.2.4
4.2.4
synckit
npm
0.11.9 up to 0.11.10
0.11.10
@pkgr/core
npm
0.2.8 up to 0.2.9
0.2.9
napi-postinstall
npm
0.3.1 up to 0.3.2
0.3.2
got-fetch
npm
5.1.11 up to 6.0.0
6.0.0

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubPaspke/scavenger_scanner2025-07-26
PoC in GitHubnihilor/cve-2025-543132025-07-26

History

History
RecordedChangedSources
exploitation
first indexedCVE List, EUVD, GitHub Advisories, CISA KEV, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-54313 is a high vulnerability (CVSS 7.5) in Prettier Eslint-config-prettier, published July 19, 2025. CISA lists it as known to be exploited, since January 22, 2026. EUVD reports exploitation since January 22, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.12%, the 92nd percentile. Fixed in eslint-config-prettier 8.10.2.

References

Show 15 moreShow less
MoveEnter Open