CVE-2025-50151
Apache Jena: Configuration files uploaded by administrative users are not check properly
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Apache Jena: Configuration files uploaded by administrative users are not check properly
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
CVE-2025-50151- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2025-22072
8.8
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
EUVD-2025-22072- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-xg9p-p463-3qjp
7.2
Apache Jena doesn't validate file access paths in configuration files uploaded by users with administrator access
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
GHSA-xg9p-p463-3qjp- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
8.8
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
CVE-2025-50151- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
8.8
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
CVE-2025-50151- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-50151
8.8
File access paths in configuration files uploaded by users with administrator access are not validated. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
DEBIAN-CVE-2025-50151- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-xg9p-p463-3qjp
7.2
Apache Jena doesn't validate file access paths in configuration files uploaded by users with administrator access
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
GHSA-xg9p-p463-3qjp- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-50151
8.8
File access paths in configuration files uploaded by users with administrator access are not validated. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
- Record
UBUNTU-CVE-2025-50151- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.jena:jenaMaven |
before 5.5.0 | 5.5.0 |
apache-jenaDebian:12 |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaDebian:13 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaDebian:14 |
All versions, plus listed versions 4.9.0-1 |
None known |
org.apache.jena:jenaMaven |
before 5.5.0, plus listed versions 2.10.02.10.12.11.02.11.12.11.2 Show 45 moreShow less2.12.02.12.12.13.02.7.12.7.22.7.32.7.43.0.03.0.13.1.03.1.13.10.03.11.03.12.03.13.03.13.13.14.03.15.03.16.03.17.03.2.03.3.03.4.03.5.03.6.03.7.03.8.03.9.04.0.04.1.04.10.04.2.04.3.04.3.14.3.24.4.04.5.04.6.04.6.14.7.04.8.04.9.05.0.05.0.0-rc15.1.0 |
5.5.0 |
apache-jenaUbuntu:22.04:LTS |
All versions, plus listed versions 3.17.0-13.17.0-23.17.0-3 |
None known |
apache-jenaUbuntu:24.04:LTS |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaUbuntu:25.10 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaUbuntu:26.10 |
All versions, plus listed versions 4.9.0-1build1 |
None known |
apache-jenaUbuntu:26.04:LTS |
All versions, plus listed versions 4.9.0-14.9.0-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-50151 is a high vulnerability (CVSS 8.8) in Apache Jena, published July 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 64th percentile. Fixed in org.apache.jena:jena 5.5.0.
References
lists.apache.org/thread/12gks5z40gh9bszn1xk8mz34gz586xss
openwall.com/lists/oss-security/2025/07/21/2
nvd.nist.gov/vuln/detail/CVE-2025-50151
github.com/advisories/GHSA-xg9p-p463-3qjp
security-tracker.debian.org/tracker/CVE-2025-50151
github.com/apache/jena
ubuntu.com/security/CVE-2025-50151
cve.org/CVERecord?id=CVE-2025-50151
Left out here: 3 versions. The JSON record has them.