CVE-2025-9308
yarnpkg Yarn request-manager.js setOptions redos
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.8
yarnpkg Yarn request-manager.js setOptions redos
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
CVE-2025-9308- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X - CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L/E:X/RL:X/RC:R - CVSS 3.0
- 3.3 Low
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L/E:X/RL:X/RC:R - CVSS 2.0
- 1.7
AV:L/AC:L/Au:S/C:N/I:N/A:P/E:ND/RL:ND/RC:UR - Weakness
- CWE-1333, CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2025-25475
4.8
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
EUVD-2025-25475- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-pfv3-xh9q-f4rq
4.8
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function...
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
GHSA-pfv3-xh9q-f4rq- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
4.8
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
CVE-2025-9308- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 1.7 Low
AV:L/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-400, CWE-1333
- Updated
- 2026-11-02
OSV
4.8
yarnpkg Yarn request-manager.js setOptions redos
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
CVE-2025-9308- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X - Weakness
- CWE-1333, CWE-400
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-9308
5.5
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
DEBIAN-CVE-2025-9308- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-9308
4.8
A vulnerability has been found in yarnpkg Yarn up to 1.22.22. This impacts the function setOptions of the file src/util/request-manager.js. Such manipulation leads to inefficient regular expression complexity. Local access is required to approach this attack. This vulnerability only affects products that are no longer supported by the maintainer.
- Record
UBUNTU-CVE-2025-9308- CVSS 4.0
- 4.8 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
node-yarnpkgDebian:12 |
All versions, plus listed versions 1.22.19+~cs24.27.18-21.22.19+~cs24.27.18-2+deb12u11.22.19+~cs24.27.18-31.22.19+~cs24.27.18-44.0.0-rc.53+dfsg-1 Show 13 moreShow less4.0.1+dfsg-14.0.1+dfsg-24.0.2+dfsg-14.0.2+dfsg-24.0.2+dfsg-34.1.0+dfsg-14.1.0+dfsg-34.1.0+dfsg-44.1.0+dfsg-54.1.0+dfsg-64.1.0+dfsg-74.1.0+dfsg-84.1.0+dfsg-9 |
None known |
node-yarnpkgDebian:13 |
before 4.0.2+dfsg-2 | 4.0.2+dfsg-2 |
node-yarnpkgDebian:14 |
before 4.0.2+dfsg-2 | 4.0.2+dfsg-2 |
node-yarnpkgUbuntu:20.04:LTS |
All versions, plus listed versions 1.13.0-1build11.13.0-31.19.1-11.22.4-2 |
None known |
node-yarnpkgUbuntu:22.04:LTS |
All versions, plus listed versions 1.22.10+~cs22.25.14-31.22.10+~cs22.25.14-41.22.10+~cs22.25.14-51.22.10+~cs22.25.14-8 |
None known |
node-yarnpkgUbuntu:24.04:LTS |
All versions, plus listed versions 1.22.19+~cs24.27.18-21.22.19+~cs24.27.18-4 |
None known |
node-yarnpkgUbuntu:25.10 |
All versions, plus listed versions 4.0.2+dfsg-34.1.0+dfsg-1 |
None known |
node-yarnpkgUbuntu:26.10 |
All versions, plus listed versions 4.1.0+dfsg-14.1.0+dfsg-6ubuntu24.1.0+dfsg-7ubuntu1 |
None known |
node-yarnpkgUbuntu:26.04:LTS |
All versions, plus listed versions 4.1.0+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-9308 is a medium vulnerability (CVSS 4.8) in Yarnpkg Yarn, published August 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.21%, the 12th percentile. Fixed in node-yarnpkg 4.0.2+dfsg-2.