Every CVE Search/ Get API key

CVE-2025-55763

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker...

7.5 HighPublic exploitFix available

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.20%Up 0.1 points since Aug 30, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
CVE-2025-55763
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2025-26228 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
EUVD-2025-26228
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-2757-2hpv-v482 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker...

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
GHSA-2757-2hpv-v482
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
NVD 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
CVE-2025-55763
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
OSV 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
CVE-2025-55763
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2025-55763 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
DEBIAN-CVE-2025-55763
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-55763 7.5

Buffer Overflow in the URI parser of CivetWeb 1.14 through 1.16 (latest) allows a remote attacker to achieve remote code execution via a crafted HTTP request. This vulnerability is triggered during request processing and may allow an attacker to corrupt heap memory, potentially leading to denial of service or arbitrary code execution.

Record
UBUNTU-CVE-2025-55763
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2026:10818-1 No score

civetweb-1.6+git1776611085.588860e3-1.1 on GA media

These are all security issues fixed in the civetweb-1.6+git1776611085.588860e3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:10818-1
Updated
2026-11-02
OSVUSN-8749-1 No score

civetweb vulnerabilities

It was discovered that CivetWeb did not correctly handle parsing certain URIs. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2025-55763)

It was discovered that CivetWeb did not correctly handle parsing certain HTTP requests. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2025-9648)

Record
USN-8749-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
civetweb
Debian:12
All versions, plus listed versions
1.15+dfsg-41.16+dfsg-11.16+dfsg-21.16+dfsg-31.16+dfsg-41.16+dfsg-5
None known
civetweb
Debian:13
before 1.16+dfsg-2+deb13u1, plus listed versions
1.16+dfsg-2
1.16+dfsg-2+deb13u1
civetweb
Debian:14
before 1.16+dfsg-3, plus listed versions
1.16+dfsg-2
1.16+dfsg-3
civetweb
Ubuntu:Pro:22.04:LTS
before 1.15+dfsg-3ubuntu0.1~esm1, plus listed versions
1.13+dfsg-51.15+dfsg-11.15+dfsg-3
1.15+dfsg-3ubuntu0.1~esm1
civetweb
Ubuntu:24.04:LTS
before 1.16+dfsg-1ubuntu0.1, plus listed versions
1.16+dfsg-11.16+dfsg-1build1
1.16+dfsg-1ubuntu0.1
civetweb
Ubuntu:25.10
All versions, plus listed versions
1.16+dfsg-2
None known
civetweb
Ubuntu:26.10
before 1.16+dfsg-3
1.16+dfsg-3
civetweb
Ubuntu:26.04:LTS
before 1.16+dfsg-3, plus listed versions
1.16+dfsg-2
1.16+dfsg-3
civetweb
Ubuntu:Pro:22.04:LTS
From an advisory covering 2 CVEs
before 1.15+dfsg-3ubuntu0.1~esm1, plus listed versions
1.13+dfsg-51.15+dfsg-11.15+dfsg-3
1.15+dfsg-3ubuntu0.1~esm1
civetweb
Ubuntu:24.04:LTS
From an advisory covering 2 CVEs
before 1.16+dfsg-1ubuntu0.1, plus listed versions
1.16+dfsg-11.16+dfsg-1build1
1.16+dfsg-1ubuntu0.1
civetweb
Ubuntu:26.04:LTS
From an advisory covering 2 CVEs
before 1.16+dfsg-3ubuntu0.1, plus listed versions
1.16+dfsg-21.16+dfsg-3
1.16+dfsg-3ubuntu0.1
civetweb
openSUSE:Tumbleweed
before 1.6+git1776611085.588860e3-1.1
1.6+git1776611085.588860e3-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubkrispybyte/CVE-2025-557632025-08-29

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-55763 is a high vulnerability (CVSS 7.5) in Civetweb Project Civetweb, published August 29, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.20%, the 68th percentile. Fixed in civetweb 1.16+dfsg-2+deb13u1.

References

Show 6 moreShow less
MoveEnter Open