Every CVE Search/ Get API key

CVE-2025-22376

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32...

5.3 MediumFix available

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.61%Up 0.6 points since Jan 4, 2025
90%50%10%1%

What each source reports

CVE List Score used 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
CVE-2025-22376
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-338, CWE-338
Updated
2026-11-02
EUVDEUVD-2025-2763 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
EUVD-2025-2763
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-w287-9q69-3hx9 9.8

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32...

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
GHSA-w287-9q69-3hx9
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-338
Updated
2026-11-02
NVD 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
CVE-2025-22376
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-338
Updated
2026-11-02
OSV 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
CVE-2025-22376
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-338
Updated
2026-11-02
OSVDEBIAN-CVE-2025-22376 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
DEBIAN-CVE-2025-22376
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2025-22376 5.3

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong.

Record
UBUNTU-CVE-2025-22376
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVMGASA-2025-0062 No score

Updated perl-Net-OAuth, perl-Crypt-URandom & perl-Module-Build packages fix security vulnerability

In Net::OAuth::Client in the Net::OAuth package before 0.29 for Perl, the default nonce is a 32-bit integer generated from the built-in rand() function, which is not cryptographically strong. (CVE-2025-22376)

Record
MGASA-2025-0062
Updated
2026-11-02
OSVopenSUSE-SU-2026:12065-1 No score

perl-Net-OAuth-0.330.0-2.1 on GA media

These are all security issues fixed in the perl-Net-OAuth-0.330.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12065-1
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
libnet-oauth-perl
Debian:12
All versions, plus listed versions
0.28-40.30-10.31-10.31-20.32-10.33-1
None known
libnet-oauth-perl
Debian:13
before 0.30-1
0.30-1
libnet-oauth-perl
Debian:14
before 0.30-1
0.30-1
perl-Net-OAuth
Mageia:9
before 0.300.0-1.mga9
0.300.0-1.mga9
perl-Crypt-URandom
Mageia:9
before 0.370.0-1.mga9
0.370.0-1.mga9
perl-Module-Build
Mageia:9
before 0.423.400-1.mga9
0.423.400-1.mga9
libnet-oauth-perl
Ubuntu:16.04:LTS
All versions, plus listed versions
0.28-2
None known
libnet-oauth-perl
Ubuntu:18.04:LTS
All versions, plus listed versions
0.28-2
None known
libnet-oauth-perl
Ubuntu:20.04:LTS
All versions, plus listed versions
0.28-3
None known
libnet-oauth-perl
Ubuntu:22.04:LTS
All versions, plus listed versions
0.28-3
None known
libnet-oauth-perl
Ubuntu:24.04:LTS
All versions, plus listed versions
0.28-4
None known
perl-Net-OAuth
openSUSE:Tumbleweed
before 0.330.0-2.1
0.330.0-2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-22376 is a medium vulnerability (CVSS 5.3) in libnet-oauth-perl, published January 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in libnet-oauth-perl 0.30-1.

References

Show 10 moreShow less
MoveEnter Open