Every CVE Search/ Get API key

CVE-2025-10930

Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110

4.3 MediumFix available

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.13%Up 0.1 points since Oct 30, 2025
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Record
CVE-2025-10930
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-352
Updated
2026-11-02
CVE List 6.5

Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Record
CVE-2025-10930
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2025-36876 6.5

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Record
EUVD-2025-36876
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-27fv-rpgj-4c6m 6.5

Drupal Currency allows Cross Site Request Forgery

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery. This issue affects Currency: from 0.0.0 before 3.5.0.

Record
GHSA-27fv-rpgj-4c6m
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-27fv-rpgj-4c6m 6.5

Drupal Currency allows Cross Site Request Forgery

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery. This issue affects Currency: from 0.0.0 before 3.5.0.

Record
GHSA-27fv-rpgj-4c6m
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-352
Updated
2026-11-02
OSVDRUPAL-CONTRIB-2025-110 No score

This module allows you to use different currencies on your website and do currency conversion.

The module doesn't sufficiently protect routes used to enable and disable currencies from Cross-Site Request Forgery (CSRF) attacks, potentially allowing an attacker to trick an admin into changing settings.

Record
DRUPAL-CONTRIB-2025-110
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/currency
Packagist
before 3.5.0
3.5.0
drupal/currency
Packagist:https://packages.drupal.org/8
before 3.5.0
3.5.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-10930 is a medium vulnerability (CVSS 4.3) in 2bits Currency, published September 24, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.13%, the 2nd percentile. Fixed in drupal/currency 3.5.0.

References

MoveEnter Open