CVE-2025-27400
Magento vulnerable to stored XSS in theme config fields
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
2.9
Magento vulnerable to stored XSS in theme config fields
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
- Record
CVE-2025-27400- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-5563
2.9
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
- Record
EUVD-2025-5563- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5pxh-89cx-4668
2.9
Magento LTS vulnerable to stored XSS in theme config fields
As reported by Aakash Adhikari, Github: @justlife4x4, the Design > Themes > Skin (Images / CSS) config field allows a Stored XSS when it contains an end script tag.
Impact
A malicious user with access to this configuration field could use a Stored XSS to affect other authenticated admin users in the admin panel.
The attack requires an admin user with configuration access, so in practice, it is not very likely to be used for gaining elevated privileges, although it could theoretically be used to impersonate other users.
- Record
GHSA-5pxh-89cx-4668- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
2.9
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
- Record
CVE-2025-27400- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
2.9
Magento vulnerable to stored XSS in theme config fields
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
- Record
CVE-2025-27400- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-5pxh-89cx-4668
2.9
Magento LTS vulnerable to stored XSS in theme config fields
As reported by Aakash Adhikari, Github: @justlife4x4, the Design > Themes > Skin (Images / CSS) config field allows a Stored XSS when it contains an end script tag.
Impact
A malicious user with access to this configuration field could use a Stored XSS to affect other authenticated admin users in the admin panel.
The attack requires an admin user with configuration access, so in practice, it is not very likely to be used for gaining elevated privileges, although it could theoretically be used to impersonate other users.
- Record
GHSA-5pxh-89cx-4668- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openmage/magento-ltsPackagist |
before 20.12.3 | 20.12.3 |
openmage/magento-ltsPackagist |
before 20.12.3, plus listed versions 1.9.1.11.9.2.01.9.2.11.9.2.21.9.2.3 Show 45 moreShow less1.9.2.41.9.3.01.9.3.1v19.4.0v19.4.1v19.4.10v19.4.11v19.4.12v19.4.13v19.4.14v19.4.15v19.4.16v19.4.17v19.4.18v19.4.19v19.4.2v19.4.20v19.4.21v19.4.22v19.4.23v19.4.3v19.4.4v19.4.5v19.4.6v19.4.7v19.4.8v19.4.9v19.5.0v19.5.0-rc1v19.5.0-rc2v19.5.0-rc3v19.5.0-rc4v19.5.0-rc5v19.5.1v19.5.2v19.5.3v20.0.0v20.0.1v20.0.10v20.0.11v20.0.12v20.0.13v20.0.14v20.0.15v20.0.16 |
20.12.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-27400 is a low vulnerability (CVSS 2.9) in Openmage Magento-lts, published February 28, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. Fixed in openmage/magento-lts 20.12.3.
References
github.com/OpenMage/magento-lts/security/advisories/GHSA-5pxh-89cx-4668
github.com/OpenMage/magento-lts/commit/d307e5bf75729a2347dde0952fe9fd9fcd9c6aea
github.com/OpenMage/magento-lts/releases/tag/v20.12.3
github.com/OpenMage/magento-lts/releases/tag/v20.13.0
nvd.nist.gov/vuln/detail/CVE-2025-27400
github.com/advisories/GHSA-5pxh-89cx-4668
github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27400.json
github.com/OpenMage/magento-lts
Left out here: 35 versions. The JSON record has them.