CVE-2026-104596
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service...
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
CVE-2026-104596- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2026-110097
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
EUVD-2026-110097- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-539p-x22q-cp96
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service...
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
GHSA-539p-x22q-cp96- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
NVD
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
CVE-2026-104596- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
CVE-2026-104596- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-104596
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
DEBIAN-CVE-2026-104596- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-104596
7.5
libosmocore through 1.14.1 contains out-of-bounds reads in the GSM 04.80 supplementary-service component parsers in src/gsm/gsm0480.c. This allows a remote attacker to obtain sensitive information.
- Record
UBUNTU-CVE-2026-104596- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libosmocoreDebian:12 |
All versions, plus listed versions 1.10.0-11.10.0-21.11.0-11.11.0-21.14.0-1 Show 5 moreShow less1.14.2-11.7.0-31.7.0-3.11.7.0-3.1~exp11.9.2-1 |
None known |
libosmocoreDebian:13 |
All versions, plus listed versions 1.11.0-21.14.0-11.14.2-1 |
None known |
libosmocoreDebian:14 |
before 1.14.2-1, plus listed versions 1.11.0-21.14.0-1 |
1.14.2-1 |
libosmocoreUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.0-4 |
None known |
libosmocoreUbuntu:18.04:LTS |
All versions, plus listed versions 0.9.0-7 |
None known |
libosmocoreUbuntu:20.04:LTS |
All versions, plus listed versions 0.12.1-30.12.1-3ubuntu1 |
None known |
libosmocoreUbuntu:22.04:LTS |
All versions, plus listed versions 1.4.2-31.6.0-31.6.0-3build1 |
None known |
libosmocoreUbuntu:24.04:LTS |
All versions, plus listed versions 1.7.0-31.7.0-3.1build11.7.0-3.1build2 |
None known |
libosmocoreUbuntu:26.10 |
All versions, plus listed versions 1.11.0-2build1 |
None known |
libosmocoreUbuntu:26.04:LTS |
All versions, plus listed versions 1.11.0-21.11.0-2build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-104596 is a high vulnerability (CVSS 7.5) in libosmocore, published October 26, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in libosmocore 1.14.2-1.
References
osmocom.org/issues/7051
github.com/osmocom/libosmocore/commit/b6c8c72c0c063ab2f293c5226472341c432454c2
nvd.nist.gov/vuln/detail/CVE-2026-104596
github.com/advisories/GHSA-539p-x22q-cp96
github.com/CVEProject/cvelistV5/tree/main/cves/2026/104xxx/CVE-2026-104596.json
security-tracker.debian.org/tracker/CVE-2026-104596