Every CVE Search/ Get API key

CVE-2026-105612

PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

3.5 Low

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.17%Unchanged since Oct 29, 2026
90%50%10%1%

What each source reports

CVE List Score used 3.5

PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Record
CVE-2026-105612
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-862
Updated
2026-11-05
EUVDEUVD-2026-112284 3.5

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Record
EUVD-2026-112284
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Updated
2026-11-05
GitHub AdvisoriesGHSA-5wcf-v8v8-f5c4 3.5

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only...

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Record
GHSA-5wcf-v8v8-f5c4
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-862
Updated
2026-11-02
NVD 3.5

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Record
CVE-2026-105612
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-862
Updated
2026-11-05
OSV 3.5

PostgreSQL Anonymizer: Data-modifying CTEs bypass the read-only restriction of masked roles

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

Record
CVE-2026-105612
CVSS 3.1
3.5 LowCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-862
Updated
2026-11-07

Affected products

History

History
RecordedChangedSources
factsEUVD
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-105612 is a low vulnerability (CVSS 3.5) in Dalibo Postgresql Anonymizer, published October 28, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 5th percentile. No source names a fixed version.

References

MoveEnter Open