Every CVE Search/ Get API key

CVE-2026-107259

Linked Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-200

5.4 MediumFix available

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.18%Unchanged since Oct 30, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.4

Linked Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-200

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Record
CVE-2026-107259
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1336
Updated
2026-11-02
EUVDEUVD-2026-113575 5.4

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Record
EUVD-2026-113575
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-wp6m-582q-3rfp 5.4

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal...

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Record
GHSA-wp6m-582q-3rfp
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1336
Updated
2026-11-02
NVD 5.4

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Record
CVE-2026-107259
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-1336
Updated
2026-11-02
OSVDRUPAL-CONTRIB-2026-200 No score

This module enables you to link the output of a field to a URL or to the value of another field.

The module doesn't sufficiently separate field content from template code when rendering linked field output. Depending on the Twig extensions installed on the site, this can be used to expose site configuration values, which may include sensitive information such as API keys or credentials.

This vulnerability is mitigated by the fact that an attacker must have a role with permission to create or edit content in a field that has Linked Field enabled in its display settings.

Record
DRUPAL-CONTRIB-2026-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/linked_field
Packagist:https://packages.drupal.org/8
before 1.8.0
1.8.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-107259 is a medium vulnerability (CVSS 5.4) in Drupal Linked Field, published October 7, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 7th percentile. Fixed in drupal/linked_field 1.8.0.

References

MoveEnter Open