CVE-2026-32277
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.7
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32277- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2026-14568
8.7
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
EUVD-2026-14568- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-cmfh-mpmf-fmq4
8.7
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Security Advisory — Cabinet Plugin (DOM-based XSS)
Summary
A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view.
Affected Versions
- 1.x series: >= 1.35.0, <= 1.41.0
- 2.x series: >= 2.35.0, <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
- Record
GHSA-cmfh-mpmf-fmq4- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
8.7
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32277- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
8.7
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32277- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-cmfh-mpmf-fmq4
8.7
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Security Advisory — Cabinet Plugin (DOM-based XSS)
Summary
A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view.
Affected Versions
- 1.x series: >= 1.35.0, <= 1.41.0
- 2.x series: >= 2.35.0, <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
- Record
GHSA-cmfh-mpmf-fmq4- CVSS 3.1
- 8.7 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensource-workshop/connect-cmsPackagist |
1.35.0 up to 1.41.1 | 1.41.1 |
opensource-workshop/connect-cmsPackagist |
2.35.0 up to 2.41.1 | 2.41.1 |
opensource-workshop/connect-cmsPackagist |
1.35.0 up to 1.41.1, plus listed versions v1.35.0v1.36.0v1.37.0v1.38.0v1.38.1v1.39.0v1.40.0v1.41.0 |
1.41.1 |
opensource-workshop/connect-cmsPackagist |
2.35.0 up to 2.41.1, plus listed versions v2.35.0v2.36.0v2.37.0v2.38.0v2.38.1v2.39.0v2.40.0v2.41.0 |
2.41.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-32277 is a high vulnerability (CVSS 8.7) in Opensource-workshop Connect-cms, published March 23, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in opensource-workshop/connect-cms 1.41.1.
References
github.com/opensource-workshop/connect-cms/security/advisories/GHSA-cmfh-mpmf-fmq4
github.com/opensource-workshop/connect-cms/commit/c04dc40f814eff891915752ef1ec00ba6612441c
github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1
nvd.nist.gov/vuln/detail/CVE-2026-32277
github.com/advisories/GHSA-cmfh-mpmf-fmq4
github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32277.json
github.com/opensource-workshop/connect-cms