Every CVE Search/ Get API key

CVE-2026-6667

PgBouncer missing authorization check in KILL_CLIENT admin command

4.3 MediumFix available

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.29%Up 0.3 points since May 9, 2026
90%50%10%1%

What each source reports

CVE List Score used 4.3

PgBouncer missing authorization check in KILL_CLIENT admin command

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
CVE-2026-6667
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-862
Updated
2026-11-02
EUVDEUVD-2026-28879 4.3

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
EUVD-2026-28879
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-gc77-jrv9-6fjp 4.3

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT...

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
GHSA-gc77-jrv9-6fjp
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-862
Updated
2026-11-02
NVD 4.3

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
CVE-2026-6667
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-862
Updated
2026-11-02
OSVDEBIAN-CVE-2026-6667 4.3

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
DEBIAN-CVE-2026-6667
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2026-6667 4.3

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
UBUNTU-CVE-2026-6667
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVAZL-86240 No score

CVE-2026-6667 affecting package pgbouncer for versions less than 1.25.2-1

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
AZL-86240
Updated
2026-11-02
OSVBIT-pgbouncer-2026-6667 No score

PgBouncer missing authorization check in KILL_CLIENT admin command

PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.

Record
BIT-pgbouncer-2026-6667
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgbouncer
Azure Linux:3
before 1.25.2-1
1.25.2-1
pgbouncer
Bitnami
before 1.25.2
1.25.2
pgbouncer
Debian:12
All versions, plus listed versions
1.18.0-11.18.0-1+deb12u11.19.0-11.19.1-11.20.0-1
Show 17 moreShow less
1.20.1-11.21.0-11.22.0-11.22.1-11.23.0-11.23.1-11.24.0-21.24.0-31.24.1-11.25.0-11.25.0-21.25.1-11.25.2-11.26.0-11.26.0-21.26.0-31.26.0-4
None known
pgbouncer
Debian:13
before 1.24.1-1+deb13u2, plus listed versions
1.24.1-11.24.1-1+deb13u1
1.24.1-1+deb13u2
pgbouncer
Debian:14
before 1.25.2-1, plus listed versions
1.24.1-11.25.0-11.25.0-21.25.1-1
1.25.2-1
pgbouncer
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5.5-11.6.1-11.7-1
None known
pgbouncer
Ubuntu:18.04:LTS
All versions, plus listed versions
1.7.2-3build11.7.2-65-g2b8e6cf-11.8.1-11.8.1-1build1
None known
pgbouncer
Ubuntu:20.04:LTS
All versions, plus listed versions
1.10.0-11.10.0-1build11.11.0-11.12.0-21.12.0-3
None known
pgbouncer
Ubuntu:22.04:LTS
All versions, plus listed versions
1.15.0-11.16.1-1ubuntu1
None known
pgbouncer
Ubuntu:24.04:LTS
All versions, plus listed versions
1.20.0-11.21.0-11.22.0-11.22.0-1build11.22.0-1build31.22.0-1build4
None known
pgbouncer
Ubuntu:25.10
All versions, plus listed versions
1.24.0-31.24.1-1
None known
pgbouncer
Ubuntu:26.10
All versions, plus listed versions
1.25.1-11.25.2-11.25.2-1ubuntu1
None known
pgbouncer
Ubuntu:26.04:LTS
All versions, plus listed versions
1.24.1-11.25.0-21.25.1-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-6667 is a medium vulnerability (CVSS 4.3) in Pgbouncer, published May 9, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in pgbouncer 1.25.2-1.

References

MoveEnter Open