Every CVE Search/ Get API key

CVE-2026-46587

Apache Camel: Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

7.3 HighPublic exploitFix available

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.69%Up 0.5 points since Jul 7, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.3

Apache Camel: Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-46587
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2026-41865 7.3

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
EUVD-2026-41865
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-46jf-c9vx-hh79 7.3

Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
GHSA-46jf-c9vx-hh79
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
NVD 7.3

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-46587
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSV 7.3

Apache Camel: Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-46587
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-46jf-c9vx-hh79 7.3

Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Record
GHSA-46jf-c9vx-hh79
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-couchbase
Maven
4.0.0 up to 4.14.8
4.14.8
org.apache.camel:camel-couchbase
Maven
4.15.0 up to 4.18.3
4.18.3
org.apache.camel:camel-couchbase
Maven
4.19.0 up to 4.21.0
4.21.0
org.apache.camel:camel-couchbase
Maven
4.0.0 up to 4.14.8, plus listed versions
4.0.14.0.24.0.34.0.44.0.5
Show 45 moreShow less
4.0.64.1.04.10.04.10.14.10.24.10.34.10.44.10.54.10.64.10.74.10.84.10.94.11.04.12.04.13.04.14.04.14.14.14.24.14.34.14.44.14.54.14.64.14.74.2.04.3.04.4.04.4.14.4.24.4.34.4.44.4.54.5.04.6.04.7.04.8.04.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.8.94.9.0
4.14.8
org.apache.camel:camel-couchbase
Maven
4.15.0 up to 4.18.3, plus listed versions
4.16.04.17.04.18.04.18.14.18.2
4.18.3
org.apache.camel:camel-couchbase
Maven
4.19.0 up to 4.21.0, plus listed versions
4.20.0
4.21.0

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHuboscerd/CVE-2026-465872026-07-15

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-46587 is a high vulnerability (CVSS 7.3) in Apache Camel, published July 6, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in org.apache.camel:camel-couchbase 4.14.8.

References

Show 9 moreShow less
MoveEnter Open