Every CVE Search/ Get API key

CVE-2026-24808

A possible integer overflow vulnerability in RawTherapee/RawTherapee

8.3 HighFix available

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Active

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
High

Exploit likelihood

0.14%Up 0.1 points since Jan 27, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.3

A possible integer overflow vulnerability in RawTherapee/RawTherapee

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Record
CVE-2026-24808
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2026-4760 8.3

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Record
EUVD-2026-4760
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Updated
2026-11-02
GitHub AdvisoriesGHSA-v546-jrfg-ph8q 8.3

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This...

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Record
GHSA-v546-jrfg-ph8q
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Weakness
CWE-190
Updated
2026-11-02
NVD 8.3

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Record
CVE-2026-24808
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Weakness
CWE-190
Updated
2026-11-02
OSV 8.3

A possible integer overflow vulnerability in RawTherapee/RawTherapee

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc.

This issue affects RawTherapee: through 5.11.

Record
CVE-2026-24808
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Weakness
CWE-190
Updated
2026-11-02
OSVDEBIAN-CVE-2026-24808 8.3

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc. This issue affects RawTherapee: through 5.11.

Record
DEBIAN-CVE-2026-24808
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Updated
2026-11-02
OSVUBUNTU-CVE-2026-24808 8.3

Integer Overflow or Wraparound vulnerability in RawTherapee (rtengine modules). This vulnerability is associated with program files dcraw.Cc. This issue affects RawTherapee: through 5.11.

Record
UBUNTU-CVE-2026-24808
CVSS 4.0
8.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/S:P/AU:Y/R:U/V:C/RE:M/U:Amber
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rawtherapee
Debian:12
All versions, plus listed versions
5.10-15.11-15.11-25.12-15.12-25.9-15.9-2
None known
rawtherapee
Debian:13
All versions, plus listed versions
5.11-25.12-15.12-2
None known
rawtherapee
Debian:14
before 5.12-1, plus listed versions
5.11-2
5.12-1
rawtherapee
Ubuntu:16.04:LTS
All versions, plus listed versions
4.2-2build14.2-4
None known
rawtherapee
Ubuntu:18.04:LTS
All versions, plus listed versions
5.2-15.3-1
None known
rawtherapee
Ubuntu:20.04:LTS
All versions, plus listed versions
5.6-15.7-15.8-1
None known
rawtherapee
Ubuntu:22.04:LTS
All versions, plus listed versions
5.8-3
None known
rawtherapee
Ubuntu:24.04:LTS
All versions, plus listed versions
5.9-1build15.9-25.10-15.10-1build35.10-1build4
None known
rawtherapee
Ubuntu:25.10
All versions, plus listed versions
5.11-2build2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-24808 is a high vulnerability (CVSS 8.3) in Rawtherapee, published January 27, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in rawtherapee 5.12-1.

References

MoveEnter Open