Every CVE Search/ Get API key

CVE-2026-74848

Apache APISIX: Cross-user response poisoning in serverless plugins

7.0 HighFix available

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
None

Exploit likelihood

0.59%Up 0.1 points since Aug 27, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.0

Apache APISIX: Cross-user response poisoning in serverless plugins

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
CVE-2026-74848
CVSS 4.0
7.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
Weakness
CWE-444
Updated
2026-11-02
EUVDEUVD-2026-66958 7.0

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
EUVD-2026-66958
CVSS 4.0
7.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-3g86-xcpq-wppj 7.0

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in...

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
GHSA-3g86-xcpq-wppj
CVSS 4.0
7.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-444
Updated
2026-11-02
NVD 7.0

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
CVE-2026-74848
CVSS 4.0
7.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-444
Updated
2026-11-02
OSV 7.0

Apache APISIX: Cross-user response poisoning in serverless plugins

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
CVE-2026-74848
CVSS 4.0
7.0 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
Weakness
CWE-444
Updated
2026-11-02
OSVBIT-apisix-2026-74848 No score

Apache APISIX: Cross-user response poisoning in serverless plugins

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.

An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.

This issue affects Apache APISIX: from 2.12.0 through 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Record
BIT-apisix-2026-74848
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apisix
Bitnami
2.12.0 up to 3.18.0
3.18.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-74848 is a high vulnerability (CVSS 7.0) in Apache Apisix, published August 27, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in apisix 3.18.0.

References

MoveEnter Open