CVE-2026-71224
Gfs2-utils: gfs2-utils: stack overflow via alloca(i_height) in metadata walk
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
4.7
Gfs2-utils: gfs2-utils: stack overflow via alloca(i_height) in metadata walk
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
CVE-2026-71224- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
EUVDEUVD-2026-70451
4.7
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
EUVD-2026-70451- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-84xm-vrh2-jhxq
4.7
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses...
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
GHSA-84xm-vrh2-jhxq- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
NVD
4.7
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
CVE-2026-71224- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-770
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-71224
4.7
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
DEBIAN-CVE-2026-71224- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-71224
4.7
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
UBUNTU-CVE-2026-71224- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-99909 No score
CVE-2026-71224 affecting package gfs2-utils 3.5.1-1
A stack overflow vulnerability was found in gfs2-utils. The metadata walk code in metawalk.c uses alloca() with an untrusted inode height value from on-disk metadata without bounds validation, causing stack exhaustion and a denial of service when processing crafted GFS2 filesystem images.
- Record
AZL-99909- Updated
- 2026-11-05
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gfs2-utilsAzure Linux:3 |
through 3.5.1-1 | None known |
gfs2-utilsDebian:12 |
All versions, plus listed versions 3.5.0-23.5.1-13.5.1-23.6.0-13.6.1-13.6.1-2 |
None known |
gfs2-utilsDebian:13 |
All versions, plus listed versions 3.6.1-13.6.1-2 |
None known |
gfs2-utilsDebian:14 |
before 3.6.1-2, plus listed versions 3.6.1-1 |
3.6.1-2 |
gfs2-utilsUbuntu:16.04:LTS |
All versions, plus listed versions 3.1.6-0ubuntu23.1.6-0ubuntu3 |
None known |
gfs2-utilsUbuntu:18.04:LTS |
All versions, plus listed versions 3.1.9-2ubuntu1 |
None known |
gfs2-utilsUbuntu:20.04:LTS |
All versions, plus listed versions 3.2.0-23.2.0-3 |
None known |
gfs2-utilsUbuntu:22.04:LTS |
All versions, plus listed versions 3.3.0-23.4.1-2 |
None known |
gfs2-utilsUbuntu:24.04:LTS |
All versions, plus listed versions 3.5.1-1 |
None known |
gfs2-utilsUbuntu:26.10 |
All versions, plus listed versions 3.6.1-1build13.6.1-2ubuntu1 |
None known |
gfs2-utilsUbuntu:26.04:LTS |
All versions, plus listed versions 3.6.1-13.6.1-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-71224 is a medium vulnerability (CVSS 4.7) in Red Hat Enterprise Linux 7, published September 3, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in gfs2-utils 3.6.1-2.