Every CVE Search/ Get API key

CVE-2026-75131

NetworkManager-l2tp Privilege Escalation via pppd Username Injection

8.5 HighFix available

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.18%Unchanged since Sep 24, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.5

NetworkManager-l2tp Privilege Escalation via pppd Username Injection

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
CVE-2026-75131
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-88
Updated
2026-11-02
EUVDEUVD-2026-85526 8.5

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
EUVD-2026-85526
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
NVD 8.5

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
CVE-2026-75131
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-88
Updated
2026-11-02
OSV 8.5

NetworkManager-l2tp Privilege Escalation via pppd Username Injection

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
CVE-2026-75131
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-88
Updated
2026-11-02
OSVDEBIAN-CVE-2026-75131 8.5

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
DEBIAN-CVE-2026-75131
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-75131 8.5

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.

Record
UBUNTU-CVE-2026-75131
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2026:11802-1 No score

NetworkManager-applet-l2tp-1.52.6-1.1 on GA media

These are all security issues fixed in the NetworkManager-applet-l2tp-1.52.6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11802-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
network-manager-l2tp
Debian:12
before 1.20.8-1+deb12u1, plus listed versions
1.20.8-1
1.20.8-1+deb12u1
network-manager-l2tp
Debian:13
before 1.20.20-2+deb13u1, plus listed versions
1.20.20-2
1.20.20-2+deb13u1
network-manager-l2tp
Debian:14
before 1.52.6-1, plus listed versions
1.20.20-21.52.0-11.52.0-21.52.2-11.52.4-1
1.52.6-1
network-manager-l2tp
Ubuntu:18.04:LTS
All versions, plus listed versions
1.2.8-11.2.8-2build1
None known
network-manager-l2tp
Ubuntu:20.04:LTS
All versions, plus listed versions
1.2.10-11.2.14-11.2.16-1
None known
network-manager-l2tp
Ubuntu:22.04:LTS
All versions, plus listed versions
1.2.18-1build11.20.0-11.20.0-1build11.20.0-1build2
None known
network-manager-l2tp
Ubuntu:24.04:LTS
All versions, plus listed versions
1.20.8-11.20.10-11.20.12-11.20.12-1build11.20.12-1build2
None known
network-manager-l2tp
Ubuntu:26.10
All versions, plus listed versions
1.52.0-21.52.2-11.52.4-11.52.4-1build11.52.6-1
None known
network-manager-l2tp
Ubuntu:26.04:LTS
All versions, plus listed versions
1.20.20-21.52.0-2
None known
NetworkManager-l2tp
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.52.6-1.1
1.52.6-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-75131 is a high vulnerability (CVSS 8.5) in Nm-l2tp Networkmanager-l2tp, published September 17, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 7th percentile. Fixed in network-manager-l2tp 1.20.8-1+deb12u1.

References

Show 4 moreShow less
MoveEnter Open