Every CVE Search/ Get API key

CVE-2026-103227

GPAC DASH Client dash_client.c gf_dash_resolve_url buffer overflow

5.3 Medium

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Passive

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.38%Down 0.1 points since Oct 1, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.3

GPAC DASH Client dash_client.c gf_dash_resolve_url buffer overflow

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
CVE-2026-103227
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
CVSS 2.0
7.5 AV:N/AC:L/Au:N/C:P/I:P/A:P/E:ND/RL:OF/RC:C
Weakness
CWE-120, CWE-119
Updated
2026-11-02
EUVDEUVD-2026-89966 5.3

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
EUVD-2026-89966
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X
Updated
2026-11-02
GitHub AdvisoriesGHSA-w83x-f8q3-9m4w 5.3

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function...

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
GHSA-w83x-f8q3-9m4w
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Weakness
CWE-119
Updated
2026-11-02
NVD 5.3

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
CVE-2026-103227
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119, CWE-120
Updated
2026-11-02
OSV 5.3

GPAC DASH Client dash_client.c gf_dash_resolve_url buffer overflow

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
CVE-2026-103227
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X
Weakness
CWE-119, CWE-120
Updated
2026-11-02
OSVUBUNTU-CVE-2026-103227 5.3

A weakness has been identified in GPAC up to 26.07.0. Affected by this issue is the function gf_dash_resolve_url of the file src/media_tools/dash_client.c of the component DASH Client. This manipulation causes buffer overflow. The attack is possible to be carried out remotely. Upgrading to version abi-16.26 can resolve this issue. Patch name: 4c8e26f278ff63eec57968f7bc696f604bb0cffd. It is recommended to upgrade the affected component.

Record
UBUNTU-CVE-2026-103227
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
gpac
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm10.5.0+svn4288~dfsg1-4ubuntu1+esm2
None known
gpac
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
None known
gpac
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
None known
gpac
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-50.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-22.0.0+dfsg1-2ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build22.2.1+dfsg1-3.1ubuntu0.1~esm2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-103227 is a medium vulnerability (CVSS 5.3) in gpac, published September 30, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. No source names a fixed version.

References

Show 8 moreShow less
MoveEnter Open