Every CVE Search/ Get API key

CVE-2026-82806

Apache APISIX: cross-request permission pollution via static permission list mutation

5.3 MediumFix available

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
None

Exploit likelihood

0.29%Down 0.1 points since Oct 2, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.3

Apache APISIX: cross-request permission pollution via static permission list mutation

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Record
CVE-2026-82806
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weakness
CWE-488
Updated
2026-11-02
EUVDEUVD-2026-90764 5.3

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Record
EUVD-2026-90764
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-2252-4rmp-q4vj 5.3

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects...

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Record
GHSA-2252-4rmp-q4vj
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-488
Updated
2026-11-02
NVD 5.3

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Record
CVE-2026-82806
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-488
Updated
2026-11-02
OSVBIT-apisix-2026-82806 No score

Apache APISIX: cross-request permission pollution via static permission list mutation

Exposure of data element to wrong session vulnerability in Apache APISIX.

This issue affects Apache APISIX: from 2.3.0 before 3.7.0.

Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions.

Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Record
BIT-apisix-2026-82806
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apisix
Bitnami
2.3.0 up to 3.7.0
3.7.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-82806 is a medium vulnerability (CVSS 5.3) in Apache Software Foundation Apisix, published October 1, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 22nd percentile. Fixed in apisix 3.7.0.

References

MoveEnter Open