Every CVE Search/ Get API key

CVE-2025-57759

Contao has improper privilege management for page and article fields

4.3 MediumFix available

Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.26%Up 0.2 points since Aug 29, 2025
90%50%10%1%

What each source reports

CVE List Score used 4.3

Contao has improper privilege management for page and article fields

Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.

Record
CVE-2025-57759
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-269
Updated
2026-11-02
EUVDEUVD-2025-26124 4.3

Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.

Record
EUVD-2025-26124
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-qqfq-7cpp-hcqj 4.3

Contao does not properly manage privileges for page and article fields

Impact

Under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions.

Patches

Update to Contao 5.3.38 or 5.6.1.

Workarounds

None.

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Record
GHSA-qqfq-7cpp-hcqj
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-269
Updated
2026-11-02
NVD 4.3

Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.

Record
CVE-2025-57759
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-269
Updated
2026-11-02
OSV 4.3

Contao has improper privilege management for page and article fields

Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.

Record
CVE-2025-57759
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-269
Updated
2026-11-02
OSVGHSA-qqfq-7cpp-hcqj 4.3

Contao does not properly manage privileges for page and article fields

Impact

Under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions.

Patches

Update to Contao 5.3.38 or 5.6.1.

Workarounds

None.

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Record
GHSA-qqfq-7cpp-hcqj
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-269
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
contao/core-bundle
Packagist
5.3.0 up to 5.3.38
5.3.38
contao/core-bundle
Packagist
5.4.0-RC1 up to 5.6.1
5.6.1
contao/contao
Packagist
5.3.0 up to 5.3.38
5.3.38
contao/contao
Packagist
5.4.0-RC1 up to 5.6.1
5.6.1
contao/core-bundle
Packagist
5.3.0 up to 5.3.38, plus listed versions
5.3.15.3.105.3.115.3.125.3.13
Show 32 moreShow less
5.3.145.3.155.3.165.3.175.3.185.3.195.3.25.3.205.3.215.3.225.3.235.3.245.3.255.3.265.3.275.3.285.3.295.3.35.3.305.3.315.3.325.3.335.3.345.3.355.3.365.3.375.3.45.3.55.3.65.3.75.3.85.3.9
5.3.38
contao/core-bundle
Packagist
5.4.0-RC1 up to 5.6.1, plus listed versions
5.4.05.4.0-RC25.4.0-RC35.4.0-RC45.4.1
Show 38 moreShow less
5.4.105.4.115.4.125.4.135.4.145.4.25.4.35.4.45.4.55.4.65.4.75.4.85.4.95.5.05.5.0-RC15.5.0-RC25.5.0-RC35.5.0-RC45.5.15.5.105.5.115.5.125.5.135.5.145.5.155.5.165.5.25.5.35.5.45.5.55.5.65.5.75.5.85.5.95.6.05.6.0-RC15.6.0-RC25.6.0-RC3
5.6.1
contao/contao
Packagist
5.3.0 up to 5.3.38, plus listed versions
5.3.15.3.105.3.115.3.125.3.13
Show 32 moreShow less
5.3.145.3.155.3.165.3.175.3.185.3.195.3.25.3.205.3.215.3.225.3.235.3.245.3.255.3.265.3.275.3.285.3.295.3.35.3.305.3.315.3.325.3.335.3.345.3.355.3.365.3.375.3.45.3.55.3.65.3.75.3.85.3.9
5.3.38
contao/contao
Packagist
5.4.0-RC1 up to 5.6.1, plus listed versions
5.4.05.4.0-RC25.4.0-RC35.4.0-RC45.4.1
Show 38 moreShow less
5.4.105.4.115.4.125.4.135.4.145.4.25.4.35.4.45.4.55.4.65.4.75.4.85.4.95.5.05.5.0-RC15.5.0-RC25.5.0-RC35.5.0-RC45.5.15.5.105.5.115.5.125.5.135.5.145.5.155.5.165.5.25.5.35.5.45.5.55.5.65.5.75.5.85.5.95.6.05.6.0-RC15.6.0-RC25.6.0-RC3
5.6.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-57759 is a medium vulnerability (CVSS 4.3) in Contao, published August 28, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. Fixed in contao/core-bundle 5.3.38.

References

MoveEnter Open