Every CVE Search/ Get API key

CVE-2020-7956

Improper Certificate Validation in HashiCorp Nomad

9.8 CriticalFix available

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.98%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
CVE-2020-7956
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
CVE-2020-7956
Updated
2026-11-02
EUVDEUVD-2021-1046 No score

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
EUVD-2021-1046
Updated
2026-11-03
GitHub AdvisoriesGHSA-cj2h-ww36-v932 9.8

Improper Certificate Validation in HashiCorp Nomad

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
GHSA-cj2h-ww36-v932
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSV 9.8

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
CVE-2020-7956
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-cj2h-ww36-v932 9.8

Improper Certificate Validation in HashiCorp Nomad

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
GHSA-cj2h-ww36-v932
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSVUBUNTU-CVE-2020-7956 9.8

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.

Record
UBUNTU-CVE-2020-7956
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGO-2022-0821 No score

Improper Certificate Validation in HashiCorp Nomad in github.com/hashicorp/nomad

Improper Certificate Validation in HashiCorp Nomad in github.com/hashicorp/nomad

Record
GO-2022-0821
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/hashicorp/nomad
Go
before 0.10.3
0.10.3
nomad
Ubuntu:18.04:LTS
All versions, plus listed versions
0.4.0+dfsg-1
None known
nomad
Ubuntu:20.04:LTS
All versions, plus listed versions
0.8.7+dfsg1-1ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-7956 is a critical vulnerability (CVSS 9.8) in Hashicorp Nomad, published January 31, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in github.com/hashicorp/nomad 0.10.3.

References

MoveEnter Open