CVE-2022-39341
OpenFGA Authorization Bypass
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (*) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.9
OpenFGA Authorization Bypass
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (*) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39341- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2022-7168
5.9
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (*) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
EUVD-2022-7168- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vj4m-83m8-xpw5
5.9
OpenFGA Authorization Bypass via tupleset wildcard
Overview
During our internal security assessment, it was discovered that OpenFGA versions v0.2.3 and prior are vulnerable to authorization bypass under certain conditions.
Am I affected?
You are affected by this vulnerability if you are using openfga/openfga version v0.2.3 and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement).
How to fix that?
Upgrade to version v0.2.4.
Backward Compatibility
This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
- Record
GHSA-vj4m-83m8-xpw5- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
NVD
5.9
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (*) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39341- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
5.9
OpenFGA Authorization Bypass
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (*) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
- Record
CVE-2022-39341- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-vj4m-83m8-xpw5
5.9
OpenFGA Authorization Bypass via tupleset wildcard
Overview
During our internal security assessment, it was discovered that OpenFGA versions v0.2.3 and prior are vulnerable to authorization bypass under certain conditions.
Am I affected?
You are affected by this vulnerability if you are using openfga/openfga version v0.2.3 and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement).
How to fix that?
Upgrade to version v0.2.4.
Backward Compatibility
This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
- Record
GHSA-vj4m-83m8-xpw5- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
OSVGO-2022-1080 No score
OpenFGA Authorization Bypass via tupleset wildcard in github.com/openfga/openfga
OpenFGA Authorization Bypass via tupleset wildcard in github.com/openfga/openfga
- Record
GO-2022-1080- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/openfga/openfgaGo |
through 0.2.3 | 0.2.4 |
github.com/openfga/openfgaGo |
before 0.2.4 | 0.2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-39341 is a medium vulnerability (CVSS 5.9) in Openfga, published October 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.14%, the 66th percentile. Fixed in github.com/openfga/openfga 0.2.4.
References
github.com/openfga/openfga/releases/tag/v0.2.4
github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5
github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695b
nvd.nist.gov/vuln/detail/CVE-2022-39341
github.com/advisories/GHSA-vj4m-83m8-xpw5
github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39341.json
github.com/openfga/openfga