Every CVE Search/ Get API key

CVE-2025-43973

GoBGP does not verify that the input length

6.8 MediumFix available

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.57%Up 0.5 points since Apr 21, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
CVE-2025-43973
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
EUVDEUVD-2025-12347 6.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
EUVD-2025-12347
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-c5jg-wr5v-2wp2 6.8

GoBGP does not verify that the input length

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
GHSA-c5jg-wr5v-2wp2
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
NVD 6.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
CVE-2025-43973
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-193
Updated
2026-11-02
OSV 6.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
CVE-2025-43973
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
OSVDEBIAN-CVE-2025-43973 9.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
DEBIAN-CVE-2025-43973
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVGHSA-c5jg-wr5v-2wp2 6.8

GoBGP does not verify that the input length

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
GHSA-c5jg-wr5v-2wp2
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Weakness
CWE-193
Updated
2026-11-02
OSVUBUNTU-CVE-2025-43973 6.8

An issue was discovered in GoBGP before 3.35.0. pkg/packet/rtr/rtr.go does not verify that the input length corresponds to a situation in which all bytes are available for an RTR message.

Record
UBUNTU-CVE-2025-43973
CVSS 3.1
6.8 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGO-2025-3633 No score

GoBGP does not verify that the input length in github.com/osrg/gobgp

GoBGP does not verify that the input length in github.com/osrg/gobgp

Record
GO-2025-3633
Updated
2026-11-02
OSVopenSUSE-SU-2025:15017-1 No score

govulncheck-vulndb-0.0.20250422T181640-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250422T181640-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15017-1
Updated
2026-11-02
OSVUSN-7661-1 No score

gobgp vulnerabilities

It was discovered that GoBGP did not properly manage memory under certain circumstances, which could lead to a buffer overflow. An attacker could possibly use this issue to cause a denial of service. This issue was only addressed in Ubuntu 22.04 LTS and Ubuntu 20.04 LTS. (CVE-2023-46565)

It was discovered that GoBGP did not properly verify the length of certain inputs. An attacker could possibly use this issue to cause a panic resulting in a denial of service. (CVE-2025-43970, CVE-2025-43971, CVE-2025-43972, CVE-2025-43973)

Record
USN-7661-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/osrg/gobgp
Go
before 3.35.0
3.35.0
github.com/osrg/gobgp/v3
Go
before 3.35.0
3.35.0
gobgp
Debian:12
All versions, plus listed versions
3.10.0-13.16.0-13.19.0-13.21.0-13.23.0-1
Show 22 moreShow less
3.25.0-13.27.0-13.28.0-13.29.0-13.30.0-13.31.0-13.32.0-13.33.0-13.35.0-13.36.0-13.36.0-24.3.0-14.4.0-14.5.0-14.5.0-1~bpo13+14.6.0-14.6.0-24.6.0-2~bpo13+14.7.0-14.7.0-1~bpo13+14.8.0-14.8.0-2~exp1
None known
gobgp
Debian:13
before 3.35.0-1
3.35.0-1
gobgp
Debian:14
before 3.35.0-1
3.35.0-1
github.com/osrg/gobgp
Go
All versions None known
gobgp
Ubuntu:Pro:18.04:LTS
before 1.29-1ubuntu0.1+esm1, plus listed versions
1.15-11.29-1
1.29-1ubuntu0.1+esm1
gobgp
Ubuntu:Pro:20.04:LTS
before 2.12.0-1ubuntu0.1~esm2, plus listed versions
1.33-12.11.0-12.12.0-12.12.0-1ubuntu0.1~esm1
2.12.0-1ubuntu0.1~esm2
gobgp
Ubuntu:Pro:22.04:LTS
before 2.25.0-3ubuntu0.1+esm2, plus listed versions
2.25.0-22.25.0-32.25.0-3build12.25.0-3ubuntu0.12.25.0-3ubuntu0.1+esm1
2.25.0-3ubuntu0.1+esm2
gobgp
Ubuntu:Pro:24.04:LTS
before 3.23.0-1ubuntu0.3+esm2, plus listed versions
3.16.0-1build13.19.0-13.21.0-13.23.0-13.23.0-1ubuntu0.1
Show 4 moreShow less
3.23.0-1ubuntu0.23.23.0-1ubuntu0.2+esm13.23.0-1ubuntu0.33.23.0-1ubuntu0.3+esm1
3.23.0-1ubuntu0.3+esm2
Show 5 moreShow less
Affected packages
PackageAffectedFixed
gobgp
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 1.29-1ubuntu0.1+esm1, plus listed versions
1.15-11.29-1
1.29-1ubuntu0.1+esm1
gobgp
Ubuntu:Pro:20.04:LTS
From an advisory covering 5 CVEs
before 2.12.0-1ubuntu0.1~esm2, plus listed versions
1.33-12.11.0-12.12.0-12.12.0-1ubuntu0.1~esm1
2.12.0-1ubuntu0.1~esm2
gobgp
Ubuntu:Pro:22.04:LTS
From an advisory covering 5 CVEs
before 2.25.0-3ubuntu0.1+esm2, plus listed versions
2.25.0-22.25.0-32.25.0-3build12.25.0-3ubuntu0.12.25.0-3ubuntu0.1+esm1
2.25.0-3ubuntu0.1+esm2
gobgp
Ubuntu:Pro:24.04:LTS
From an advisory covering 5 CVEs
before 3.23.0-1ubuntu0.3+esm2, plus listed versions
3.16.0-1build13.19.0-13.21.0-13.23.0-13.23.0-1ubuntu0.1
Show 4 moreShow less
3.23.0-1ubuntu0.23.23.0-1ubuntu0.2+esm13.23.0-1ubuntu0.33.23.0-1ubuntu0.3+esm1
3.23.0-1ubuntu0.3+esm2
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 23 CVEs
before 0.0.20250422T181640-1.1
0.0.20250422T181640-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-43973 is a medium vulnerability (CVSS 6.8) in Gobgp, published April 21, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in github.com/osrg/gobgp 3.35.0.

References

Show 32 moreShow less
MoveEnter Open