Every CVE Search/ Get API key

CVE-2019-1000016

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in...

6.5 MediumFix available

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.11%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
CVE-2019-1000016
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-129
Updated
2026-11-02
CVE List No score

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
CVE-2019-1000016
Updated
2026-11-02
EUVDEUVD-2019-1735 No score

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
EUVD-2019-1735
Updated
2026-11-03
GitHub AdvisoriesGHSA-hc9w-x35j-3w9c 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in...

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
GHSA-hc9w-x35j-3w9c
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-129
Updated
2026-11-02
OSVALPINE-CVE-2019-1000016 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
ALPINE-CVE-2019-1000016
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
CVE-2019-1000016
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-1000016 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
DEBIAN-CVE-2019-1000016
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVJLSEC-2025-101 6.5

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in...

FFMPEG version 4.1 contains a CWE-129: Improper Validation of Array Index vulnerability in libavcodec/cbs_av1.c that can result in Denial of service. This attack appears to be exploitable via specially crafted AV1 file has to be provided as input. This vulnerability appears to have been fixed in after commit b97a4b658814b2de8b9f2a3bce491c002d34de31.

Record
JLSEC-2025-101
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.10
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.11
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.12
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.13
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.14
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.15
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.16
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.17
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.18
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.19
before 4.1.1-r0
4.1.1-r0
Show 16 moreShow less
Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.20
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.21
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.22
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.23
before 4.1.1-r0
4.1.1-r0
ffmpeg
Alpine:v3.24
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.16
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.17
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.18
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.19
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.20
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.21
before 4.1.1-r0
4.1.1-r0
ffmpeg4
Alpine:v3.22
before 4.1.1-r0
4.1.1-r0
ffmpeg
Debian:12
before 7:4.1.1-1
7:4.1.1-1
ffmpeg
Debian:13
before 7:4.1.1-1
7:4.1.1-1
ffmpeg
Debian:14
before 7:4.1.1-1
7:4.1.1-1
FFMPEG_jll
Julia
before 4.3.1+0
4.3.1+0

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-1000016 is a medium vulnerability (CVSS 6.5) in Ffmpeg, published February 4, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.11%, the 66th percentile. Fixed in ffmpeg 4.1.1-r0.

References

MoveEnter Open